Recent

Author Topic: RX library  (Read 40392 times)

jack616

  • Sr. Member
  • ****
  • Posts: 266
RX library
« on: October 28, 2013, 03:23:11 pm »
I have a quite large application I wrote about 10 years ago with Delphi-3 c/s that uses
the rx library.
I currently maintain this with my D3 package but I would really like to update it now
into laz/fpc.

I see there is an RX library implementation and I have had a quick go at porting over
but there is too much that probably wont ever work.

My best solution seems to be to re-write the entire app taking out the specialist RX
functions and replacing with standard Delphi components that should then port. After this
I can "re-upgrade" the app with up to date modifications (better string grids etc)
Because I have most functions isolated into units I shouldn't have too complex
a problem to cope with but still...

Obviously this is quite a lot of work so I thought I'd just ask first if anyone knows
a better way to go about this particular issue?

TIA


wp

  • Hero Member
  • *****
  • Posts: 6309
Re: RX library
« Reply #1 on: October 28, 2013, 07:57:44 pm »
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

jack616

  • Sr. Member
  • ****
  • Posts: 266
Re: RX library
« Reply #2 on: October 29, 2013, 03:27:14 pm »

 ?

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7495
Re: RX library
« Reply #3 on: October 29, 2013, 04:01:58 pm »
I assume that that is a maintained version of the RX components for Lazarus. Might not contain all components though, and not always on all targets.

 Sometimes intrinsically unportable components are left out.

wp

  • Hero Member
  • *****
  • Posts: 6309
Re: RX library
« Reply #4 on: October 29, 2013, 05:21:57 pm »
Quote
?
Sorry for the confusion. You can download the Lazarus version of RX components from this link (click on "trunk" and "Download snapshot"). I once had installed RX in Delphi 4 or so. After having done a test install in Lazarus the component palette looks similar to that, but as marcov said the components probably are not complete. But maybe you give it a try. At least the ccr RX components are actively maintained, the last update of RxDBGrid is from today.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

jack616

  • Sr. Member
  • ****
  • Posts: 266
Re: RX library
« Reply #5 on: October 30, 2013, 02:20:43 pm »
Thanks for explaining.

I had a go with the library before posting here but couldn't see an easy way to get it to recognise the old string grid
and labels and things (I used RX a lot because it seemed really useful a the time) The best I could do was to
delete the components. Renaming them didn't seem to help either. (I have codetyphon installed)

I guess I'm asking too much and had better just  knuckle down and get the work done.
(If I have missed something please feel free to interupt me anytime!)

Thanks though.

eldonfsr

  • Full Member
  • ***
  • Posts: 131
Re: RX library
« Reply #6 on: November 10, 2013, 07:10:18 am »
Compilent error rxlib
C:\lazarus\componentes\Rx2.1\rxdbgrid.pas(629,15) Error: There is no method in an ancestor class to be overridden: "TRxDBGrid.GetBufferCount:LongInt;"

i download to day.

wp

  • Hero Member
  • *****
  • Posts: 6309
Re: RX library
« Reply #7 on: November 10, 2013, 07:31:23 pm »
I can compile and install the package with fpc 2.7.1. The commonly used fpc 2.6.2, however, fails.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

sin_dragan

  • Full Member
  • ***
  • Posts: 127
Re: RX library
« Reply #8 on: December 26, 2013, 09:11:07 pm »
Hi, I ve instaled rxnew package from trunk (version 2.6.1.134) on 1.0.8, 2.6.2 everything compiles fine. When I put component RxDBGrid on form, I get access violation.

I ve tried to install 2.5.2.134 and 2.4.6 I get same result. When I try to create component from code I get Project raised exception class 'EResNotFound with message: Resource "picDateEdit" not found. Also tooledit.pas at line 851 - External SIGSEGV


Windows 7 64 bit
Lazarus 1.4.1 (w/fixes) FPC 2.6.4 win32

wp

  • Hero Member
  • *****
  • Posts: 6309
Re: RX library
« Reply #9 on: December 26, 2013, 09:31:09 pm »
I do get the access violation for RxDBGrid with 1.0.14 / fpc 2.6.2 or with 1.2RC1 / fpc 2.6.2, but do not for Laz trunk / fpc 2.6.2.

You should post a report in the bug tracker.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

sin_dragan

  • Full Member
  • ***
  • Posts: 127
Re: RX library
« Reply #10 on: December 26, 2013, 10:38:29 pm »
Same here, I tried different versions + the 1.1 with 2.7.1, always the same.

Thank you, I 'll try the latest trunk and also report this bug.
Windows 7 64 bit
Lazarus 1.4.1 (w/fixes) FPC 2.6.4 win32

sin_dragan

  • Full Member
  • ***
  • Posts: 127
Re: RX library
« Reply #11 on: December 26, 2013, 11:17:07 pm »
I tried with trunk version 43595 but still it gives me AV when I put RxDBGrid or TDBDateEdit component on form.

What revision do you use?
Windows 7 64 bit
Lazarus 1.4.1 (w/fixes) FPC 2.6.4 win32

wp

  • Hero Member
  • *****
  • Posts: 6309
Re: RX library
« Reply #12 on: December 27, 2013, 12:59:17 am »
Just updated to the same revision, no issues. Strange...
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

sin_dragan

  • Full Member
  • ***
  • Posts: 127
Re: RX library
« Reply #13 on: December 27, 2013, 10:44:14 pm »
Strange indeed :)

What version of Rx did you installed, is there any extra steps needed?

I see that th CT uses the 2.4.8 version, but with fpc 2.7.1, I need working version with 2.6.2.
Windows 7 64 bit
Lazarus 1.4.1 (w/fixes) FPC 2.6.4 win32

wp

  • Hero Member
  • *****
  • Posts: 6309
Re: RX library
« Reply #14 on: December 28, 2013, 12:34:04 am »
When I compile rxnew the message windows tells me that it's the 2.6.1.134 - it is the version in ccr/components/rx/trunk which I am occasionally updating by using TortoiseSVN. I am just installing the rxnew package, I don't know if it is necessary to install the old rx package as well, but I think I did this some time before (to be found in in Lazarus: Package / Install/uninstall packages / rx1.0)

I'm not a specialist for rx, but I'd prefer the later package because the svn log tells me that there have been some recent fixes of RxDBGrid.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10