Recent

Author Topic: Tutorial - Android & Lazarus for novices like me  (Read 59135 times)

axel234

  • New Member
  • *
  • Posts: 10
Re: Tutorial - Android & Lazarus for novices like me
« Reply #45 on: February 26, 2017, 07:51:20 pm »
Originally in AndroidManifest.xml the SDK line is:
<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="14"/>

and in Build.xml the SDK line is:
<property name="target"  value="android-14"/>

I've tried this:

Changing the first line to:
<uses-sdk android:minSdkVersion="17" android:targetSdkVersion="14"/>
then build. I got an error message.

Then changing the first line to:
<uses-sdk android:minSdkVersion="17" android:targetSdkVersion="17"/>
Error.

Then changing the first line to:
<uses-sdk android:minSdkVersion="17" android:targetSdkVersion="14"/>
AND the build.xml line to:
<property name="target"  value="android-17"/>
Error occured.

Then, the first line to:
<uses-sdk android:minSdkVersion="17" android:targetSdkVersion="17"/>
AND the build.xml line to:
<property name="target"  value="android-17"/>

Unfortunatelly I got an error message as well.


jmpessoa

  • Hero Member
  • *****
  • Posts: 1470
Re: Tutorial - Android & Lazarus for novices like me
« Reply #46 on: February 26, 2017, 08:17:16 pm »


Please, try a new project!!

Set minSdk = 17

and set tarqet to some >= 17

[While I'm here correcting the framework  to it work when api < 17!  :-X]

Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

axel234

  • New Member
  • *
  • Posts: 10
Re: Tutorial - Android & Lazarus for novices like me
« Reply #47 on: February 26, 2017, 08:52:41 pm »
Each try I made, was on the new project.

Ok, so I'll wait for you to finish the api work.
Please post here the corrected framework.

Thank you very much for your help.

jmpessoa

  • Hero Member
  • *****
  • Posts: 1470
Re: Tutorial - Android & Lazarus for novices like me
« Reply #48 on: February 26, 2017, 09:33:26 pm »


After fix the minSdk and Target Api.... what is your message error?
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

axel234

  • New Member
  • *
  • Posts: 10
Re: Tutorial - Android & Lazarus for novices like me
« Reply #49 on: February 26, 2017, 11:02:32 pm »
I've tried again, not by editing any of the .xml files manually, but selecting the MinSdkApi 14 and TargetSdkApi 19 in Module Wizard while creating a new project and it looks like it's working fine :)
Lately when I was editing the .xml files manually according to your instructions, I wasn't changing anything in Module Wizard while creating a new project (because you didn't tell me to), and that was in my opinion causing errors.

PS If my English is poor, sorry for that, I'm Polish.

jmpessoa

  • Hero Member
  • *****
  • Posts: 1470
Re: Tutorial - Android & Lazarus for novices like me
« Reply #50 on: February 26, 2017, 11:38:46 pm »

Ok!

The question was just minSdk =  14  !!! Some component work
only for minSdk >= 17

[but I will Fix it now!]

Thank you!
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

apexcol

  • Jr. Member
  • **
  • Posts: 54
Re: Tutorial - Android & Lazarus for novices like me
« Reply #51 on: June 24, 2017, 04:49:43 am »
Hi, did anyone install Android to work with Lazarus on Ubuntu?  Any place where to get info on doing that step-by-step? ::)

jmpessoa

  • Hero Member
  • *****
  • Posts: 1470
Re: Tutorial - Android & Lazarus for novices like me
« Reply #52 on: June 25, 2017, 07:44:28 pm »

You can try  [LAMW]  "how to"  for linux   [by renabor]

https://github.com/jmpessoa/lazandroidmodulewizard/tree/master/docs/linux
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard