Author Topic: LazSqlX  (Read 126987 times)


  • Guest
Re: LazSqlX
« Reply #210 on: February 26, 2015, 10:33:28 pm »
Thanks for help LacaK. I tried the 2000 and 2008 lib but same; the only difference I noticed with 2008 lib is that it takes a bit longer before raising the exception "TMSSQLConnection : Error 20009 :
Unable to connect: Adaptive Server is unavailable or does not exist" though it connects to 2005,2008,2012


  • Hero Member
  • *****
  • Posts: 607
Re: LazSqlX
« Reply #211 on: February 27, 2015, 09:40:11 am »
I have strong suspection, that it is related to SQL Server configuration.
May be, that server requires encryption and rejects connection when not set etc.

I am sure, that it is not related to TDS protocol version or db-library itself.


  • Hero Member
  • *****
  • Posts: 607
Re: LazSqlX
« Reply #212 on: February 28, 2015, 09:08:37 am »
Or open on server "SQL Server Configuration Manager" and check there if TCP/IP protocol is enabled.
It will be usefull also switch-on on client side logging, using freetds.conf, then we will see what is going on.


  • Guest
Re: LazSqlX
« Reply #213 on: March 01, 2015, 12:36:34 am »
thank you very much LacaK, I'll try what you suggested as soon as I get back to lazsqlx


Yes you were right! TCP/IP protocol was not enabled by default. After enabling it, I restarted the service and it could connect to mssql server 2014 right away :) . Thank you!
« Last Edit: March 01, 2015, 01:24:55 pm by flamer0n »


  • Guest
Re: LazSqlX
« Reply #214 on: March 02, 2015, 10:30:24 pm »

-TableList in UI changed to Treeview with expandable table items
-Changed some colors
-Changed MainIcon (and some others)

SQLite improvements:
-Sqlite foreign key extraction from ddl [AsSqliteMetadata] (kind of..)
-Better field type mapping when cloning to Sqlite from other database types [sqlite]
-New data types added for Sqlite3: varchar,datetime[sqlite]

-Fix field length [AsSqliteMetadata]

-Improvements in cloning to Sqlite (creates constraints,better data type mappings)
-Added option to create or not the foreign key constraints
-Added option to copy data (experimental)
Note: except for Sqlite, constraints will be created after copying data. When you have
constraints in your source db when cloning to sqlite, expect failure in copy data.

-Firebird embedded libraries included

...and bugfixes

Compiled with Lazarus 1.4RC2
« Last Edit: March 02, 2015, 10:33:26 pm by flamer0n »


  • Hero Member
  • *****
  • Posts: 832
    • HowTos Considered Harmful?
Re: LazSqlX
« Reply #215 on: June 05, 2015, 01:41:16 am »
I downloaded the latest precmpiled version, as well as compiling the latest version from source, and when I connect to a PostgreSQL version, the list of tables does not appear. The connection appears to succeed though.
Any ideas of what it might be?

Does it have some preferences that can be added at runtime to help with debugging?
For instance Zeos can log the output so you can see the exact commands and responses passed to the server. If it can be activate at runtime that wold be a great help.
Lazarus 2.0.6/FPC 3.0.4


  • Hero Member
  • *****
  • Posts: 668
    • exdatis
Re: LazSqlX
« Reply #216 on: June 05, 2015, 10:07:12 am »
I tried this : v. with Firebird3.0 without success(Sqldb and Zeos).
In my opinion a good solution is to add protocol-options(for zeos) and option to save path for a client lib which can be used to load_library(Sqldb) or path in ZConnection.
I suppose that there is no problem if you have environment_variable-settings-path.

p.s. looks nice!


  • Newbie
  • Posts: 1
Re: LazSqlX
« Reply #217 on: June 09, 2015, 01:35:54 am »

Congratulations for LazSqlX. That's a nice tool!

I would like to suggest you a small correction. With Firebird Embedded's files, deployed with LazSqlX, it would be nice also to deploy these files:

Code: [Select]

Without them, any query might answer:

Code: [Select]
: Fetch : 
-CHARACTER SET XXXXX is not installed

if your tables use some Character Set for collation control.




  • Full Member
  • ***
  • Posts: 158
  • Using FPC in Windows, Linux, Macos
Re: LazSqlX
« Reply #218 on: June 09, 2015, 11:14:11 pm »
Hi, I was working on porting and running MacOS lazsqlx also function as a client for SQLServer.
Finally it succeeds in compiling libraries freetds 32bit architecture (such as binary generated FPC). And make some changes in fpc sources because i use sqldb.

I leave a screenshot, and if anyone is interested, I can see leaving binaries.


Build freetds for use in 32bits in osx
Code: [Select]
tar -xvzf ./freetds-patched.tar.gz
cd freetds-0.95.0
./configure --with-tdsver=7.3 CFLAGS="-arch i386"
sudo make install

Changes in FPC source:

Line:16-> Change to:   MSSQLOSes           = [beos,haiku,linux,freebsd,netbsd,openbsd,solaris,win32,win64,android,dragonfly,darwin];

And i add (manually in the sqldblaz.lpk include library to mssqlconn.pp directory)
        <OtherUnitFiles Value="../../../fpc/packages/fcl-db/src/sqldb/mssql/;../../../fpc/packages/dblib/src"/>

« Last Edit: June 10, 2015, 12:10:46 am by esvignolo »


  • Full Member
  • ***
  • Posts: 225
Re: LazSqlX
« Reply #219 on: June 09, 2015, 11:35:19 pm »
I downloaded (beta) and use it with SQLDB/MySQL, works OK.
It's a bit slow for some features (example, table properties), but all in all it's good.
Also liked the visual  query designer.


  • Hero Member
  • *****
  • Posts: 2090
    • Additional info
Re: LazSqlX
« Reply #220 on: March 14, 2016, 11:49:00 am »
I have a problem connecting to Oracle on WinXP SP3. Main web page says LazSqlX works on Windows, but I get an error message which seam to indicate that Vista and up is requested according to this MS document:

Can anyone confirm this? Is this global or my local problem?

I can connect from Typhon, Toad and EMS SQL Manager on that pc.
« Last Edit: March 14, 2016, 11:50:53 am by avra »
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib


  • New Member
  • *
  • Posts: 20
Re: LazSqlX
« Reply #221 on: April 01, 2016, 12:29:53 pm »

I have question.
Under what license is LazSqlX released?
I see that there is no licensing info in installation nor in code tree.



  • New Member
  • *
  • Posts: 20
Re: LazSqlX
« Reply #222 on: April 04, 2016, 11:18:40 pm »
Hi again

I found
with information like this
Free open source mini SqlManager for SqlServer,Oracle,MySql,Firebird,Postgres,Sqlite

So what exactly is LazSQLX license and where it is stated? BSD, MIT, MPL, GPL, LGPL, AGPL, Public Domain?

For example FPC/Lazarus licensing is LGPL with linking exception - FPC modified LGPL.

Twitter is not legal document. In reality LazSQLX license can be - Proprietary commercial software. Maybe all of LazSQLX users are now using software, that costs e.g. USD 3000.

Any thoughts? Under what licensing terms users are using this software? In many countries software users can get in big trouble if using unlicensed software.


  • Hero Member
  • *****
  • Posts: 1251
Re: LazSqlX
« Reply #223 on: April 04, 2016, 11:59:58 pm »
Flameron doesn't appear to be active on this forum right now.

Try here

Last commit appears to be only a month ago, so the project is still active.

And I sincerely doubt flameron has uploaded code just to ensare his users with a USD3000 bill.   But sure, if you feel that's possible, don't use it.
Lazarus Trunk/FPC Trunk on Windows [7, 10]
  Have you tried searching this forum or the wiki?:
  BOOKS! (Free and otherwise):


  • New Member
  • *
  • Posts: 13
Re: LazSqlX
« Reply #224 on: March 23, 2018, 12:03:43 pm »

The libmySQL.dll file which comes bundled with LazSqlX is detected as a virus / trojan by a significant number of security vendors. Including the latest MSI marking it as a trojan and deleting it automatically. VirusTotal reports 11 / 63.

Also reported here:


TinyPortal © 2005-2018