Recent

Author Topic: Android Module Wizard  (Read 505325 times)

Almir Lima

  • New member
  • *
  • Posts: 32
    • iSoft Tecnlogia Digital
Re: Android Module Wizard
« Reply #1065 on: June 26, 2018, 12:53:54 am »
I'm study the project, i'm compiling the demos, but any sometimes not work or not Compil, like the component of the Camera and any of TAB ( Android Bridges Support ).

When i use the button, Take photo. The APP stop.

I have using Android 6.0 ( API 23 ), SDK 28.0.0,  jdk1.8.0_171 and i execute it in Phone with Android 8.0.

I have ones questions.
What´s ANT and GRADLE?

What's the minimum version to execute the App make with the tool?

Today better than yesterday.

jmpessoa

  • Hero Member
  • *****
  • Posts: 1368
Re: Android Module Wizard
« Reply #1066 on: June 26, 2018, 02:04:12 am »

Hello Almir!

Quote
What´s ANT and GRADLE?

Ant and Gradle are builder-systems to compile and "build" android APK

You need Gradle  when select "AppCompat" themes and "Android Bridges Support" palete/components...

but for simple/default projects Ant is ok...
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

Almir Lima

  • New member
  • *
  • Posts: 32
    • iSoft Tecnlogia Digital
Re: Android Module Wizard
« Reply #1067 on: June 26, 2018, 04:20:51 am »
exist a method to configure the IDE to use two version of compiler, ARM and WIN 32 like a Delphi. would like compile projects Windows and Projects Android without have use other instance of IDE.

Parabéns pelo trabalho Pessoa.
Today better than yesterday.

jmpessoa

  • Hero Member
  • *****
  • Posts: 1368
Re: Android Module Wizard
« Reply #1068 on: June 26, 2018, 04:52:55 am »

Ola Almir!

A good solution is install "laz4android"

https://sourceforge.net/projects/laz4android/

(laz4android =  lazarus for windows + cross compile for android)

More info here: https://github.com/jmpessoa/lazandroidmodulewizard/blob/master/LAMW%20Getting%20Started.txt
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

BjPascal

  • New member
  • *
  • Posts: 15
Re: Android Module Wizard
« Reply #1069 on: July 16, 2018, 12:55:19 am »
using Lazarus 1.9.0 and FPC 3.1.1 on Win7 x64

Installing LAMW with OPM failed to compile amw_ide_tools
and reports:
   Cannot install package: "amw_ide_tools.lpk"

Any idea how to fix it ?

jmpessoa

  • Hero Member
  • *****
  • Posts: 1368
Re: Android Module Wizard
« Reply #1070 on: July 16, 2018, 04:48:00 am »

Hi BjPascal!

Please, try to install from:

https://github.com/jmpessoa/lazandroidmodulewizard

Thank you!
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

sameer

  • New member
  • *
  • Posts: 12
Re: Android Module Wizard
« Reply #1071 on: July 18, 2018, 10:50:00 am »
Hi,

I am using LAMW + Win32 + Laz4Android + SDK27 + NDK24 + JDK1.8.

The AppDBGridView example compiles and works fine on emulator. However, if i create a new project which contains component DBGridview then i get the following error :

Code: Diff  [Select]
  1. Panic:     [javac] d:\lamw\PoS_Mad\src\org\lamw\pos_mad\android-27\jDBListView.java:90: error: cannot find symbol

Please advice.

jmpessoa

  • Hero Member
  • *****
  • Posts: 1368
Re: Android Module Wizard
« Reply #1072 on: July 18, 2018, 09:30:11 pm »

Hi sameer!

Look for "jDBListView.java" in  LAMW folder "......\java\lamwdesigner"

if  the file exists then delete  the jDBListView componet from Form designer
and do  "run->build"

Now put again the jDBListView componet  in the form...
and do  "run->build"
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

jmpessoa

  • Hero Member
  • *****
  • Posts: 1368
Re: Android Module Wizard
« Reply #1073 on: August 22, 2018, 06:27:02 am »
Hi All,

There is a  new LAMW revision!

Version 0.8 - rev 02 - 21 - August - 2018

NEW! Added support to App "Runtime Permission" [Required by "target" Api >= 23]

UPDATED!! demo "AppCameraDemo"  ["Runtime Permission" example...]

NEW!  jsAdMob component [thanks to TR3E]
           warning: Need "AppCompat" theme...

NEW demo "AppCompatAdMobDemo1"


Thansk to All
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1105
Re: Android Module Wizard
« Reply #1074 on: August 22, 2018, 07:26:54 am »
Quote
NEW! Added support to App "Runtime Permission" [Required by "target" Api >= 23]
Very important feature on new Androids ! Thanks very much !!

jmpessoa

  • Hero Member
  • *****
  • Posts: 1368
Re: Android Module Wizard
« Reply #1075 on: August 26, 2018, 07:38:50 am »
Hi All!

UPDATED!! LAMW demos:

"AppLocationDemo1" 
"AppSMSDemo1" 

["Runtime Permission" example... targeting API >= 23]
« Last Edit: August 26, 2018, 07:40:35 am by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

CC

  • Full Member
  • ***
  • Posts: 119
Re: Android Module Wizard
« Reply #1076 on: August 27, 2018, 08:53:51 am »
jmpessoa,

Stability is very important and I figured it is probably best to use the same/closest possible version to what you are working with.
But I am confused about which SDK and build/tools/platform-tools/build-tools  version to use with LAMW.

http://wiki.lazarus.freepascal.org/LAMW says that R24.4.1.  But SDK manager does not recognize this version and the downloaded zip file does not seem to contain all files needed to work out of the box.

Is there any risk using a more recent NDK?


jmpessoa

  • Hero Member
  • *****
  • Posts: 1368
Re: Android Module Wizard
« Reply #1077 on: August 27, 2018, 05:57:38 pm »
Hi,  CC!

1) For not "AppCompat" themes  you can use/target any recent API .... [warning: the R24.4.1 is the last that support "ant" builder]   ... Recommended: target 21 or 22 [not run permission is required !!!]

2) Yes, R24.4.1  [or any...] is not "complete" out of box...

[from "LAMW getting started.txt"]
                1)after unpacked [R24.4.1 or any...], open a terminal and go to "sdk/tools"  folder
      2)run  cmd "android sdk" to open a GUI "SDK Manager"
      3)check "Android SDK Tools"
      4)check "Android SDK Platform-Tools"
      
      5)check "Android SDK Build-Tools 25.0.3" [need for "gradle" builder]    

      5.1)check  "Android SDK Build-Tools 26.0.2"  [need for "gradle" builder]
      
      6)go to "Android 7.1.1 (API 25)" and check  "SDK Platform" [need for "AppCompat" themes and "gradle" builder]

      7)go to "Extras" and check:
            "Android Support Repository"            
            "Android Support Library"            
            "Google USB Drive"
 
3) For "AppCompat" themes the only "recommended"  for LAMW:

"Android SDK Build-Tools 25.0.3" [need by old "gradle" plugin]    
"Android SDK Build-Tools 26.0.2"  [need by 3.0.1  "gradle" plugin ...]
"Android 7.1.1 (API 25)"
"Extras":          "Android Support Repository"            
            "Android Support Library"            
 
« Last Edit: August 27, 2018, 07:19:31 pm by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

abssistemas

  • New member
  • *
  • Posts: 21
Re: Android Module Wizard
« Reply #1078 on: August 30, 2018, 01:41:10 pm »
Hello

I'm using the jTCPSocketClient component in an android project and need to send a 1024 bytes sequence, but it can not send bytes, only string by the jTCPSocketClient.SendMessage command.
It would have a way to send bytes instead of text.

Thank you.

Handoko

  • Hero Member
  • *****
  • Posts: 3084
  • My goal: build my own game engine using Lazarus
Re: Android Module Wizard
« Reply #1079 on: August 30, 2018, 02:29:38 pm »
You can write you own functions for converting bytes to text string and the opposite.

I ever read the discussion about it but I forgot where to find it.