Bookstore

Recent

Author Topic: Error writing to remote device(emulator)  (Read 2661 times)

epergola

  • Full Member
  • ***
  • Posts: 136
Error writing to remote device(emulator)
« on: April 25, 2013, 09:18:45 pm »
Hi

Long time I haven't been on this forum...
I am trying to run my app on the WM6.1 emulator, but I get this error:
(debugger output)
~"Uploading file to device: \\Storage Card\\app.exe\n"
&"error writing to remote device - 0.\n"
I use -eval-command="set remotedirectory \Storage Card" in Tools->Options->Debugger.

My app is 22.6 Mb, band runs fine when I copy manually to the sharedforlder and run directly form WM 6.1 emulator, but the debugger copies always 2.41 MB and then gets the error.
Any idea why?
I am using Lazarus 1.0.8, SVN Rev 40573.
The error came out of the blue ski.
I had just fixed some problems with  building the app correctly, and did run fine a few times on the WM 6.1.
Then there it comes the error.
I even reset the emulator, re-booted the PC (XP). I ran out of ideas....
Any Help?

felipemdc

  • Administrator
  • Hero Member
  • *
  • Posts: 3541
Re: Error writing to remote device(emulator)
« Reply #1 on: May 01, 2013, 03:22:39 am »
I followed precisely these instructions and it worked for me with the 6.5 emulator:

http://wiki.freepascal.org/Windows_CE_Interface#Debugging_Windows_CE_software_on_the_Lazarus_IDE