Recent

Author Topic: Can't compile anything  (Read 2208 times)

EdyKnopfler

  • New Member
  • *
  • Posts: 12
Can't compile anything
« on: April 03, 2013, 01:05:23 am »
I have just installed Lazarus 1.0.4 on Fedora and tried to do my first compilation (in this case, rebuild the IDE for installing a component package) and I've got the messages below (the packages were compiled well, the problem occurred when linking). So I tried to compile a simple project and the problem was the same.

/usr/bin/ld: warning: link.res contains output sections; did you forget -T?
/lib/libEGL.so.1: undefined reference to `wl_display_dispatch_queue_pending'
project1.lpr(20,1) Error: Error while linking
project1.lpr(20,1) Fatal: There were 1 errors compiling module, stopping

Leledumbo

  • Hero Member
  • *****
  • Posts: 8281
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Can't compile anything
« Reply #1 on: April 03, 2013, 11:49:57 am »
Wow! Fedora already uses Wayland? :o
I don't have any idea what package contain the function, you should consult your package manager to find wayland development library.

 

TinyPortal © 2005-2018