Recent

Author Topic: can't compile Sdpo on RasPi  (Read 2498 times)

jomixl

  • Newbie
  • Posts: 3
can't compile Sdpo on RasPi
« on: January 22, 2013, 06:32:03 pm »
hello,
i just tried to install Sdpo-0.2.0(5dpo) on my RasPi and got some error like: Identifier not found'B500000'

Has anybody succeded installing Sdpo on a Raspi with Raspian?

regards joachim

Motherjoker

  • New member
  • *
  • Posts: 6
Re: can't compile Sdpo on RasPi
« Reply #1 on: February 21, 2014, 01:25:44 am »
I don't think this is the best solution, but it worked for my LazSerial's installation
If you don't need highest baudrates you can remove them: comment/remove these lines from synaser.pas
    ,(500000, B500000),
    (576000, B576000),
    (921600, B921600),
    (1000000, B1000000),
    (1152000, B1152000),
    (1500000, B1500000),
    (2000000, B2000000),
    (2500000, B2500000),
    (3000000, B3000000),
    (3500000, B3500000),
    (4000000, B4000000)
and change this
    MaxRates = 30; //UNIX
to this
    MaxRates = 19; //UNIX

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7627
Re: can't compile Sdpo on RasPi
« Reply #2 on: February 21, 2014, 11:13:25 am »
Fixing the SDPO source code so that it determines that table runtime using the enum (and removing the B) is best. Then it is also future proof against the next modification