Forum > Suggestions

Need precompiled cross-compiler installed

(1/1)

cst_zf:
i find compiling from source is difficult and preventing my friends to use fpc & lazarus. I believe lazarus and fpc can produce good software and it is the only choice to generate native software everywhere except c&c++.

However, not every one is a expert in buiding the IDE and compiler system. Precompiled package (Win Installer, deb, rpm) can help us to advance further.

Why not deploy the JVM-Java, JVM-andriod, iOS... target with the  normal installation package? After installing Lazarus from sourceforge downloading page, the shining target will attract more and more people and companys to enter the battleline of Lazarus. I  believe it is absolutely a good way to advance.

wjackson153:
Whats wrong with

http://sourceforge.net/projects/lazarus/files/

Has precompiled binary for FPC and Lazarus

PS a compiled application does not need to pass FPC librarys to the user as they are compiled
into the application, nor do the end user need to install Lazarus to use your app.

cst_zf:
I know FPC uses static linking so that deployment is not the problem.
However cross-compiler system is not included in the installer.
We should package cross-compiler system in it, with options in the installer to let the developer choose whether he will install it.
Cross-compiler system is attractive in my opnion but pascal is not today.
If we can make it easy to use, fpc&lazarus have the chance to become popular again. The chance today is in mobile world, and freepascal can do it, why not let others to find this thing easily?

Leledumbo:

--- Quote ---Why not deploy the JVM-Java, JVM-andriod, iOS... target with the  normal installation package?
--- End quote ---

* There are more than 20 combinations of arch-os pair supported by FPC, that would be about nearly 20 ^ 2 packages if we provide one for each cross host-cross target pair
* Who's gonna maintain all that (actual problem, IMO)?

marcov:

--- Quote from: cst_zf on December 27, 2012, 04:22:30 am ---
Why not deploy the JVM-Java, JVM-andriod,

--- End quote ---

They are highly experimental, and thus not ready for the end-user stage.


--- Quote --- iOS... target with the 

--- End quote ---

iOS can only be compiled from Apple systems. And there is a crosscompiler for Apple systems.
 

Navigation

[0] Message Index

Go to full version