Forum > PDAs and Smartphones

Unable to compile Lazarus on raspberry pi

(1/4) > >>


I am trying to compile Lazarus on my raspberry pi. I have the raspian image installed and updated. I have installed fpc 2.6.0 from the repositories, but the repo only has lazarus 0.9.30. I want to compile Lazarus 1.0.2 but the compile fails near the end with the following message:

Free Pascal Compiler version 2.6.0-6+rpi1 [2012/11/16] for arm
Copyright (c) 1993-2011 by Florian Klaempfl and others
Target OS: Linux for ARMHF
Compiling lazarus.pp
Compiling main.pp
Assembling main
main.pp(19362) Error: Can't call the assembler, error -9 switching to external assembling
main.pp(19362) Fatal: There were 2 errors compiling module, stopping
Fatal: Compilation aborted
make[2]: *** [lazarus] Error 1
make[2]: Leaving directory `/home/jkotze/lazarus/ide'
make[1]: *** [ide] Error 2
make[1]: Leaving directory `/home/jkotze/lazarus/ide'
make: *** [ide] Error 2

I can compile normal (non - gui) freepascal apps without issues.

Any ideas ?

I think you are using the Debian repo, so it is so old.
Have you ever tried with the latest svn trunk?
You can follow the following page.

I am using fpc 2.6.0 which is the current stable version. I also downloaded Lazarus 1.0.2  source and tried to compile that. I have in the meantime managed to compile a Lazarus project and it runs. I just cannot seem to compile the IDE.

hi i have same problem you must install binutils-dev

--- Code: ---sudo apt-get install binutils-dev
--- End code ---


--- Quote from: zirkonxx on November 30, 2012, 02:00:57 am ---
--- Code: ---sudo apt-get install binutils-dev
--- End code ---

--- End quote ---
I am also facing the same problem, and installing binutils-dev does not make any difference.

The reason for me to compile the ide is only at I want to install the Zeos package - anyone having any ideas?



[0] Message Index

[#] Next page

Go to full version