Recent

Author Topic: No SQLdb tab  (Read 6020 times)

defiler

  • Newbie
  • Posts: 1
No SQLdb tab
« on: February 07, 2006, 08:31:06 pm »
Hello , After compiling and installing sqldblaz.lpk as per the documentation there is no sqldb tab as stated in the documentation. I have tried removing the package and reinstalling it, removing it under Componets/Configure Installed Packages and adding it back (save and build ide) .  No luck Any Ideas?

sqlpython

  • New member
  • *
  • Posts: 6
No SQLdb tab
« Reply #1 on: May 07, 2006, 07:35:45 am »
Using Lazarus 0.9.10 and FPC 2.0.1 I was able to install the SQLdb tab with TxxConnections no problem but.........
mysql4laz.lpk will not install nor will the interbase.lpk..

Take a look at my Linux post of 5/7/06  re mysql4laz.lpk

matthijs

  • Hero Member
  • *****
  • Posts: 537
No SQLdb tab
« Reply #2 on: May 07, 2006, 12:15:57 pm »
What OS are you on? If you are on Linux, check ~/.lazarus/ directory.
What's in a sig? Would my posting look less if it didnot have a sig? (Free after William S.) :)

:( Why cannot I upload my own Avatar? :(

sqlpython

  • New member
  • *
  • Posts: 6
No SQLdb tab
« Reply #3 on: May 07, 2006, 06:13:15 pm »
Thanks for pointing out the /home/user/.lazarus   "hidden dir"

But it seems form looking at ./lararus/packagefiles.xml  that my package config is not right even after several reinstalls of Lazarus and numerous package installs and removes..
I simply want the packages that will allow me to work with MySQL 4 which I belive are sqldblaz.lpk  and mysql4laz.lpk. I can install sqldblaz no problem..
Here is my packagefiles.xml contents ...
It seems to include the mysql3laz package which I don't believe I need or want with mysql4 database..

Opinions? FIxes?

<CONFIG>
-
   <UserPkgLinks Count="3">
-
   <Item1>
<Name Value="MySQL3Laz"/>
<Version Minor="1" Release="1"/>
<Filename Value="/usr/lib/lazarus/components/mysql/mysql3laz.lpk"/>
</Item1>
-
   <Item2>
<Name Value="Sqldblaz"/>
<Version Major="1"/>
<Filename Value="/usr/lib/lazarus/components/sqldb/sqldblaz.lpk"/>
</Item2>
-
   <Item3>
<Name Value="sqlitedslaz"/>
<Version Minor="2"/>
<Filename Value="/usr/lib/lazarus/components/sqlite/sqlitedslaz.lpk"/>
</Item3>
</UserPkgLinks>
</CONFIG>

sqlpython

  • New member
  • *
  • Posts: 6
No SQLdb tab
« Reply #4 on: May 07, 2006, 06:30:12 pm »
Yet when I look in the IDE at /Components/Configure Packages/Installed Packages
..I only see
FCL 1.0
LCL 1.0
Sqldblaz 1.0
IDEIntf 1.0
SynEdit 1.0

Can I correct the differences between this and the config in ./lazarus/packagefiles.xml without an IDE reininstall?

matthijs

  • Hero Member
  • *****
  • Posts: 537
No SQLdb tab
« Reply #5 on: May 07, 2006, 06:47:47 pm »
You do not need mysql4laz.lpk. Only sqldb package is enough to work with mySQL, Interbase or Postgres databases.
What's in a sig? Would my posting look less if it didnot have a sig? (Free after William S.) :)

:( Why cannot I upload my own Avatar? :(

Anonymous

  • Guest
No SQLdb tab
« Reply #6 on: May 07, 2006, 07:08:52 pm »
Thank you..Is there a man page or WIKI tutorial regarding sql statements through the Pascal program after the Connection?

2. Should I do something to modify the ./lazarus/packagefiles.xml  which appears to have unnecessary packages listed..
Will they effect the IDE operations..?

Anonymous

  • Guest
No SQLdb tab
« Reply #7 on: May 07, 2006, 07:09:49 pm »
Sorry..should have also asked..Then what is the use of the mysql4laz.lpk  ?