Forum > Packages and Libraries

[Solved] Rebuild IDE can not find custom package compiled unit

(1/1)

eny:
I've created a custom package for a new project type (some time ago).
In the previous stable version 0.9.30 it installed correctly.
However when I now try to install it with the latest stable build I get some kind of unit not found message. This is caused by the fact that now Lazarus does more checks than it did in the previous version when building the IDE (see the two message lines with the white I's in front).

Any suggestions as to what I might need to change to get it installed correctly into this version of the IDE?

<<Edit>>
Forgot to mention one thing: when compiling the package it now (with this Lazarus version) cannot find the Project unit  %)

eny:
Never new that changing settings in a package that is not even installed could break Lazarus: been playing around with the unit and include paths of the package mentioned above.
And now Lazarus fails to build.

eny:
Some more info: other new project IDE plugins gave the same error (unit Project not found), like here: http://www.lazarus.freepascal.org/index.php/topic,8651.msg41771.html#msg41771.
IIRC this is where I got the example code to develop my plugin.

So the question basically is: is anybody using a custom New Project wizard in the IDE with the latest IDE version?

<<Edit>>
Seems there was an invalid reference to the TProject type (should not have been used in the first place  >:().
Changing it to TLazProject fixed it (for anyone who encounters the same problem).

Navigation

[0] Message Index

Go to full version