Recent

Author Topic: Lazreport designer shows just a gray panel, no rep design objects on AMD64 Linux  (Read 12098 times)

tkramer3

  • New Member
  • *
  • Posts: 15
I tried some different themes, and I also downloaded some new themes and tried them, but it did not solve this problem. I am using KDE 4.8.5 too.

jesusr

  • Sr. Member
  • ****
  • Posts: 470
Sadly I removed my kubuntu install here. Once I reproduced the problem and confirmed changing the default theme solved the issue, I overwrote kubuntu VM with something else (/me is not in love with KDE anymore, specially when using old equipment). If I remember correctly, is not the Kde theme, is was the settings that make GTK to look alike KDE or the GTK2 theme used.

jesusr

  • Sr. Member
  • ****
  • Posts: 470
Ok, I gave him another chance to Kubuntu.

I can confirm that Oxygen-gtk theme is the responsible for this bug, if you run the program as this way:
Code: [Select]
$ OXYGEN_DISABLE_INNER_SHADOWS_HACK=1 ./theprogram (or ./lazarus)
the problem disappear, but there is another artifact, the scrollbars on designer are not painted, they are functional but there are only empty spaces where the scrollbar should appear. It must be another oxygen-gtk problem but I have not investigated too much about another command line workaround.

Instead, in revision 40585 and 40586 I modified the report designer to overcome this problem

neodarkman

  • New Member
  • *
  • Posts: 35
I installed and configured the theme QtCurve GTK to use it. Hence the problem was solved.

tkramer3

  • New Member
  • *
  • Posts: 15
I tried the OXYGEN...HACK.... from the post of Jesusr, unfortunately that didn't work.

Also I tried the daily snapshot, with Fpc 2.6.0 and Lazarus 1.1.40672, this worked OK under Kubuntu - AMD64

And finally I installed the latest release, Lazarus 1.0.8 with fpc 2.6.2. This did not work. But after installing QTcurve (just with apt-get install qtcurve)  and switching in KDE system settings-> Application Appearance-> GTK+ Appearance -> Widget Style (under GTK+ Styles) -> QtCurve (Or any other style except Oxygen-gtk) it also worked.

Oxygen-gtk is the default in this setting. After switching back to this default and restarting Lazarus the gray panel reappeared.

So with the two options I've got right now I am very happy, thank you Jesus and Neodarkman for this results.
« Last Edit: March 31, 2013, 05:00:45 pm by tkramer3 »