Recent

Author Topic: Can't comlipe IDE  (Read 7801 times)

Alexeysh

  • New member
  • *
  • Posts: 6
Can't comlipe IDE
« on: September 03, 2012, 01:26:41 pm »
I
1. installed lazarus-1.0-fpc-2.6.0-win32.exe to C:\lazarus
2. installed lazarus-1.0-fpc-2.6.0-cross-arm-wince-win32.exe to C:\lazarus

3. Set
LCL Widget Type: wince
Target OS: wince
Target CPU Family: arm

4. Tryed to rebuild IDE
Fisrt i had a error (pic1)

5. I excluded package printer4lazarus 0.5 and turbopoweripro 1.0 from installation and tryed to rebuild

I got error
C:\lazarus\components\jcf2\Utils\JcfStringUtils.pas(169,3) Fatal: Syntax error, "identifier" expected but "," found
(pic2) and dont know what to do.

It seems some compiler option is not defined.



Leledumbo

  • Hero Member
  • *****
  • Posts: 8111
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Can't comlipe IDE
« Reply #1 on: September 03, 2012, 04:38:09 pm »
Seems like neither MSWindows nor Unix is defined for WinCE. I don't think you can build the IDE for WinCE (Running the IDE from a WinCE device? Are you serious?), don't build the IDE, just LCL and packages available to WinCE (printers? unsure).

Alexeysh

  • New member
  • *
  • Posts: 6
Re: Can't comlipe IDE
« Reply #2 on: September 04, 2012, 08:39:18 am »
1.
I thought that it was necessary to develop applications for WinCE
I do not know how to rebuild only the LCL and packages for WinCE.
How can i do it?

2.
Now, I tried to set the compiler C:\lazarus\fpc\2.6.0\bin\i386-win32\ppcrossarm.exe
Got error "Can't find fpc.cfg" but this file is located in the same directory.
What i'm doing wrong?
« Last Edit: September 04, 2012, 09:33:58 am by Alexeysh »

felipemdc

  • Administrator
  • Hero Member
  • *
  • Posts: 3541
Re: Can't comlipe IDE
« Reply #3 on: September 04, 2012, 09:49:33 am »
1.
I thought that it was necessary to develop applications for WinCE
I do not know how to rebuild only the LCL and packages for WinCE.
How can i do it?

You don't need to do this manually. You configure your own project in the menu "Project->Project Options" to widgetset WinCE, operatingsystem WinCE and architecture ARM and build your project.

If necessary, Lazarus will automatically rebuild the LCL and all other dependencies that you project has.

Quote
2.
Now, I tried to set the compiler C:\lazarus\fpc\2.6.0\bin\i386-win32\ppcrossarm.exe
Got error "Can't find fpc.cfg" but this file is located in the same directory.
What i'm doing wrong?

Yet another thing that you don't need to do. You can leave the compiler to fpc.exe

Alexeysh

  • New member
  • *
  • Posts: 6
Re: Can't comlipe IDE
« Reply #4 on: September 04, 2012, 03:54:15 pm »
You don't need to do this manually. You configure your own project in the menu "Project->Project Options" to widgetset WinCE, operatingsystem WinCE and architecture ARM and build your project.
I don't see place to set widgetset in "Project->Project Options", only operating system and processor. (pic1)
Can you show it, please.

when i set only operating system and processor and try to compile simple project, i got an error (pic2)
win32\win32wsdialogs.pp(0,0) Fatal: Can not find unit shlobj used by Win32WSDialogs.

when i try to test settings, i got another  error (pic3)
Error: C:\lazarus\fpc\2.6.0\bin\i386-win32\ppcrossarm.exe returned an error exitcode (normal if you did not specify a source file to be compiled)

It'strange to see 'LCL -dLCLwin32' in compiler parameters. Does is matters?
 
Quote
C:\lazarus\fpc\2.6.0\bin\i386-win32\fpc.exe  -MObjFPC -Scghi -O1 -Twince -Parm -g -gl -va -l -FiC:\LP\lib\arm-wince -FuC:\lazarus\lcl\units\arm-wince\win32 -FuC:\lazarus\lcl\units\arm-wince -FuC:\lazarus\components\lazutils\lib\arm-wince -FuC:\lazarus\packager\units\arm-wince -FuC:\LP\ -FUC:\LP\lib\arm-wince\ -dLCL -dLCLwin32 C:\DOCUME~1\alexeysh\LOCALS~1\Temp\testcompileroptions.pas

taazz

  • Hero Member
  • *****
  • Posts: 5363
Re: Can't comlipe IDE
« Reply #5 on: September 04, 2012, 04:42:30 pm »
Go to  "Build Modes" on the tree,  select LCLWidgetType in the macro name and select the widget you want from macro value.
Good judgement is the result of experience … Experience is the result of bad judgement.

OS : Windows 7 64 bit
Laz: Lazarus 1.4.4 FPC 2.6.4 i386-win32-win32/win64

Leledumbo

  • Hero Member
  • *****
  • Posts: 8111
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Can't comlipe IDE
« Reply #6 on: September 04, 2012, 05:36:37 pm »
Quote
It'strange to see 'LCL -dLCLwin32' in compiler parameters. Does is matters?
Yes, it does. WinCE has its own LCL interface and will generate a different define if chosen.

Alexeysh

  • New member
  • *
  • Posts: 6
Re: Can't comlipe IDE
« Reply #7 on: September 06, 2012, 09:51:20 am »
Thank you, all.

I compiled and run my first application on WinCE succesfully  :D