Recent

Author Topic: Debug with root privileges?  (Read 4659 times)

fig2k4

  • Newbie
  • Posts: 4
Debug with root privileges?
« on: September 07, 2012, 04:59:27 am »
My app needs raw access to drives, which requires root privileges.  Is there any way to debug this app from Lazarus? 

When I run the app from the IDE, the various function calls fail because of lack of permissions.  When I use gksu to run normally, the calls succeed.  I really need to be able to debug it though. 

Any suggestions?

fig2k4

  • Newbie
  • Posts: 4
Re: Debug with root privileges?
« Reply #1 on: September 07, 2012, 11:00:13 am »
Since I run Ubuntu in a VM, solely to use lazarus, this is the best solution for me.

http://www.liberiangeek.net/2012/05/login-as-root-in-ubuntu-12-04-precise-pangolin/

Max JRB

  • New Member
  • *
  • Posts: 11
    • JaxmaxBlogIT
Re: Debug with root privileges?
« Reply #2 on: October 04, 2012, 08:37:40 pm »
Did you try to run Lazarus as root?

wjackson153

  • Sr. Member
  • ****
  • Posts: 267
Re: Debug with root privileges?
« Reply #3 on: December 26, 2012, 06:15:40 pm »
ummm there is no need to open lazarus in root, all you need to do is

open a terminal and type :
sudo lazarus-ide

If it says your user is not in sudoers then simply

sh root

once your @root prompt

nano /etc/sudoers

add your user to the list of   ALLOWED ROOT USERS
%admin ALL=(ALL) ALL
Lazarus 1.1 r39490 CT FPC 2.7.1 i386-linux KDE
Linux Mint 14 KDE 4