Forum > macOS / Mac OS X

Unable to get it to install...

<< < (2/3) > >>

Anonymous:
Ok... I got it working!  I did a fresh install of Apple X11 then re-ran the fink command.  This time fink did TONS more stuff and took almost 5 minutes to complete!

I then tried to run Lazarus... "cannot open display".  I tried startlazurus.  Same deal.

So I went and ran the X11.app and started it from xTerm... It worked!  Looks REALLY nice!

Phil H.:
That's good news.

You can drag and drop the X11 app onto your dock to have a one-click way of starting X11.

To simplify starting Lazarus, in X11, choose Applications | Customize, then click Add Item. Under Name enter Lazarus, under Command enter the following:

open -a /usr/local/share/lazarus/lazarus

Click Done to close. Now you can start Lazarus from X11 simply by choosing Applications | Lazarus.

-Phil

Anonymous:

--- Quote from: "mattias" ---Where did you find the instruction, that you should install gtkglarea?

You don't need it.
--- End quote ---


If gtkglarea isn't needed, maybe this should be changed:

http://wiki.lazarus.freepascal.org/index.php/Installing_Lazarus#Installing_Free_Pascal_under_Mac_OS_X

Anonymous:
Thats kind of what I hinted at above... To make this less confusing the install docs should be updated.

Thanks for the idea Phil!

Anonymous:
Phil,

Not sure why but that command doesn't work either from the application window or from xterm

open -a /usr/local/share/lazarus/lazarus

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version