Recent

Author Topic: OpenGL 2.0 with Ubuntu 10.4  (Read 2499 times)

Ocye

  • Hero Member
  • *****
  • Posts: 518
    • Scrabble3D
OpenGL 2.0 with Ubuntu 10.4
« on: May 22, 2012, 10:37:13 pm »
My program does not run if I load OpenGL2.0 extensions [glext_LoadExtension('GL_version_2_0');]. ldd tells me that libGL.so.1 is linked to /usr/lib/mesa/libGL.so.1 - seems to be okay. What can I recommend to users, or do I need to remove 2.0 stuff from code?

Ubuntu 11.4 is okay (when unity-style scrollbars are removed); Mint 12 has never had any problem (both 32bit), and all other distros run without any complains. Ubuntu sucks!
Lazarus 1.7 (SVN) FPC 3.0.0