Recent

Author Topic: i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4  (Read 6349 times)

delphi887

  • New Member
  • *
  • Posts: 30
    • my personal website
i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4
« on: April 19, 2012, 08:29:44 am »
hi
i use Lazarus 0.9.30.2 and zcomponent 6.6.6 but when upgrade Lazarus to 0.9.30.4 and try to
compile and install zcomponent 6.6.6 error occurred

C:\lazarus\components\ZEOSDBO-6.6.6-stable\src\core\ZClasses.pas(84,22) Error: No matching implementation for interface method "IUnknown.QueryInterface(constref TGuid,out <Formal type>):LongInt; StdCall;" found

please help me
thanks

ludob

  • Hero Member
  • *****
  • Posts: 1173
Re: i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4
« Reply #1 on: April 19, 2012, 09:17:37 am »
Type Zeos and QueryInterface in the little search box and you'll find a lot of recent posts on the subject:
http://forum.lazarus.freepascal.org/index.php/topic,16630.0.html
http://www.lazarus.freepascal.org/index.php/topic,16615.msg90552.html#msg90552

delphi887

  • New Member
  • *
  • Posts: 30
    • my personal website
Re: i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4
« Reply #2 on: April 20, 2012, 02:50:42 pm »
thanks ludob
 :) ;)

Stilgar

  • New Member
  • *
  • Posts: 16
Re: i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4
« Reply #3 on: April 28, 2012, 12:33:05 am »
ZClasses.pas

At line 68 you can find this
Code: [Select]
{$IFDEF FPC} change in
Code: [Select]
{$IFDEF FPC_1}  .
Replay the change at line 194.

The good definition for lazarus, you can find at line 297 of objpash.inc into Lazarus\fpc\2.6.0\source\rtl\inc\ folder.

Stilgar

elidorio

  • Sr. Member
  • ****
  • Posts: 295
Re: i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4
« Reply #4 on: May 03, 2012, 05:53:02 pm »
Lazarus 1.4.4 | FPC 2.6.4 | Windows / Linux Debian

jeanchristophe

  • Jr. Member
  • **
  • Posts: 88
Re: i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4
« Reply #5 on: May 09, 2012, 12:02:28 pm »
If the solutions above are not working, use 0.9-30.2 in sted.
Looks like it is working fine for me.

Best Regards
Jean-Christophe

ludob

  • Hero Member
  • *****
  • Posts: 1173
Re: i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4
« Reply #6 on: May 09, 2012, 12:54:22 pm »
If the solutions above are not working, use 0.9-30.2 in sted.
The lazarus version is not relevant. The fpc version is. Lazarus 0.9.30.2 shipped with fpc 2.4.4, Lazarus 0.9.30.4 uses fpc 2.6.0.

Fortuna1

  • Full Member
  • ***
  • Posts: 164
Re: i can not open package zcomponent 6.6.6 in lazarus 0.9.30.4
« Reply #7 on: May 09, 2012, 06:06:11 pm »
 Lazarus 0.9.30.2


In this version is bug.

You must  click twice ( DBGridP1.CellClick ) ;

 The last good version is Lazarus 0.9.30.0.

Leave Zeoslib  and I am shifting per Tibconnection.

I will finish still some week with crossing.
« Last Edit: May 09, 2012, 06:09:33 pm by Fortuna1 »

 

TinyPortal © 2005-2018