Forum > LazReport

Instalation problem again

(1/1)

klacus:
Hi.

With 0.9.34 I try to install Lazreport  I got the following message

/usr/lib/lazarus/0.9.30.4/ide/lazarus.pp(1,1) Fatal: Can't find unit lazreport used by Lazarus



startlazarus --debug
Adding "--debug" as a parameter
TLazarusManager.Run DefaultDir="/usr/lib/lazarus/0.9.30.4/" CustomDir="/home/kozma/.lazarus/bin/"
TLazarusManager.Run starting /usr/lib/lazarus/0.9.30.4/lazarus ...
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/home/kozma/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
TMainIDE.DoNewProject A
TPkgManager.SaveAutoInstallDependencies A Printer4Lazarus
TPkgManager.SaveAutoInstallDependencies A SDFLaz
TPkgManager.SaveAutoInstallDependencies A RunTimeTypeInfoControls
TPkgManager.SaveAutoInstallDependencies A printers4lazide
TPkgManager.SaveAutoInstallDependencies A MemDSLaz
TPkgManager.SaveAutoInstallDependencies A TurboPowerIPro
TPkgManager.SaveAutoInstallDependencies A jcfidelazarus
TPkgManager.SaveAutoInstallDependencies A ChmHelpPkg
TPkgManager.SaveAutoInstallDependencies A fpcunitide
TPkgManager.SaveAutoInstallDependencies A ProjTemplates
TPkgManager.SaveAutoInstallDependencies A TAChartLazarusPkg
TPkgManager.SaveAutoInstallDependencies A ToDoListLaz
TPkgManager.SaveAutoInstallDependencies A DBFLaz
TPkgManager.SaveAutoInstallDependencies A lazreport
TPkgManager.SaveAutoInstallDependencies A SQLDBLaz
TPkgManager.SaveAutoInstallDependencies A lazreportpdfexport
TPkgManager.SaveAutoInstallDependencies A Printer4Lazarus
TPkgManager.SaveAutoInstallDependencies A SDFLaz
TPkgManager.SaveAutoInstallDependencies A RunTimeTypeInfoControls
TPkgManager.SaveAutoInstallDependencies A printers4lazide
TPkgManager.SaveAutoInstallDependencies A MemDSLaz
TPkgManager.SaveAutoInstallDependencies A TurboPowerIPro
TPkgManager.SaveAutoInstallDependencies A jcfidelazarus
TPkgManager.SaveAutoInstallDependencies A ChmHelpPkg
TPkgManager.SaveAutoInstallDependencies A fpcunitide
TPkgManager.SaveAutoInstallDependencies A ProjTemplates
TPkgManager.SaveAutoInstallDependencies A TAChartLazarusPkg
TPkgManager.SaveAutoInstallDependencies A ToDoListLaz
TPkgManager.SaveAutoInstallDependencies A DBFLaz
TPkgManager.SaveAutoInstallDependencies A lazreport
TPkgManager.SaveAutoInstallDependencies A SQLDBLaz
TPkgManager.SaveAutoInstallDependencies A lazreportpdfexport
TMainIDE.DoBuildLazarus: Compile AutoInstall Packages failed.



I try to reinstall the fpc, lazarus at several times.
I check fpc.cfg, I think is ok. I compare with 0.9.28 files and settings, all is the same -except on fpc version-

So I do not know what shuld I do. The Lazarus did not find the units, but why???? Everithing quite well...

I check, and use a Goggle but did not find any solutions....

Somebody pls. help.

braximo:
had a similar problem. I don't know if it would work with you but i changed the folder permissions of lazreport to 777. Hope it helps.

exdatis:
   Try installation from CodeTyphon studio. I use CT2.5 and I have no any problem. I use XUbuntu 12.4 and Win7.

Regards.

JuhaManninen:
There is also a wiki-page about the possible reasons:
  http://wiki.lazarus.freepascal.org/Unit_not_found_-_How_to_find_units

Juha

klacus:
I tried it. But not work.

Finally if remove Ubuntu now, because it has a lot of other problems. under Debian everything quite well.

Navigation

[0] Message Index

Go to full version