Recent

Author Topic: What to install ?  (Read 6441 times)

Fred vS

  • Hero Member
  • *****
  • Posts: 1675
    • miXimum is the DJ's best friend
What to install ?
« on: December 28, 2011, 08:24:11 pm »
Hello everybody.
I have developed a DJ's program also for Linux (https://sites.google.com/site/fiensprototyping/) with Ubuntu 10.04 and Lazarus.
The program was compiled in Linux with QT widgetset.

Now i have installed a brand new Ubuntu 11.10.
Unfortunately, the Qt libraries and Qt for Pascal libraries are not installed by default with Ubuntu (they are installed when you install Lazarus).
And after the install of the DJ program, it does not load, because some Qt libraries are missing  %).

Witch easy command in console must the free customers and i use to install all that missing libraries for every new linux distributions (without Lazarus installed) ?

For example :

Code: [Select]
sudo apt-get install qt-lib qt4pas
Many thanks and happy new year.  :P
« Last Edit: December 28, 2011, 08:29:31 pm by Fred vS »
I use Lazarus 1.8.0 32/64 and FPC 3.0.3 32/64 on Linux Mint Mate 17 32/64, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs

Fred vS

  • Hero Member
  • *****
  • Posts: 1675
    • miXimum is the DJ's best friend
Re: What to install ?
« Reply #1 on: January 01, 2012, 08:43:42 pm »
Hey everybody.
Is there someone awake?
Many thanks for helping me.
HNY
I use Lazarus 1.8.0 32/64 and FPC 3.0.3 32/64 on Linux Mint Mate 17 32/64, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs

BigChimp

  • Hero Member
  • *****
  • Posts: 5740
  • Add to the wiki - it's free ;)
    • FPCUp, PaperTiger scanning and other open source projects
Re: What to install ?
« Reply #2 on: January 01, 2012, 08:57:38 pm »
Have you searched the wiki and forums? Installing the general Qt libs should be easy I should think - and is not Lazarus/FPC specific.

Apart from that, I think you need Qt4pas or something, made by Den Jean.

(Haven't done any of this, just what I remembered).

Good luck.

Edit: quick search in the wiki turned up this:
http://wiki.lazarus.freepascal.org/index.php/Qt_Interface
Hope it is helpful; if not could you update it please?
« Last Edit: January 01, 2012, 09:00:31 pm by BigChimp »
Want quicker answers to your questions? Read http://wiki.lazarus.freepascal.org/Lazarus_Faq#What_is_the_correct_way_to_ask_questions_in_the_forum.3F

Open source including papertiger OCR/PDF scanning:
https://bitbucket.org/reiniero

Lazarus trunk+FPC trunk x86, Windows x64 unless otherwise specified

Fred vS

  • Hero Member
  • *****
  • Posts: 1675
    • miXimum is the DJ's best friend
Re: What to install ?
« Reply #3 on: January 01, 2012, 09:59:14 pm »
@ BigChimp.
Thanks for your help.
about : http://wiki.lazarus.freepascal.org/index.php/Qt_Interface

Why so complicated  :o ? Is there somebody who knows witch dependencies to install with a simple command from terminal (like sudo apt-get install qt-lib) ?

PS: Why does it not exists a easy script to install QT and QT for Pascal for dummies people like me ?

PS2 : I like Qt, more than GTK, but, Qt developers, please help us, we normal humans, to install and use it.

Many thanks
« Last Edit: January 01, 2012, 10:05:02 pm by Fred vS »
I use Lazarus 1.8.0 32/64 and FPC 3.0.3 32/64 on Linux Mint Mate 17 32/64, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs

ludob

  • Hero Member
  • *****
  • Posts: 1173
Re: What to install ?
« Reply #4 on: January 02, 2012, 08:55:54 am »
Quote
Why so complicated  :o ? Is there somebody who knows witch dependencies to install with a simple command from terminal (like sudo apt-get install qt-lib) ?
From https://launchpad.net/ubuntu/oneiric/i386/libqt4pas5/2.1Qt4.5.3-5.1ubuntu1 download libqt4pas5_2.1Qt4.5.3-5.1ubuntu1_i386.deb and run
Code: [Select]
sudo gdebi libqt4pas5_2.1Qt4.5.3-5.1ubuntu1_i386.deb
Or just double click on the file in nautilus. It'll pull in all qt4 libs needed.

Fred vS

  • Hero Member
  • *****
  • Posts: 1675
    • miXimum is the DJ's best friend
Re: What to install ?
« Reply #5 on: January 09, 2012, 09:08:52 pm »
@ ludob
Thanks my friend, that is perfectly easy and clear.  ;D
I use Lazarus 1.8.0 32/64 and FPC 3.0.3 32/64 on Linux Mint Mate 17 32/64, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs

Fred vS

  • Hero Member
  • *****
  • Posts: 1675
    • miXimum is the DJ's best friend
Re: What to install ?
« Reply #6 on: January 09, 2012, 09:30:58 pm »
@ ludob.
Thanks for the !386 deb file.
But what about the 64 bits (amd64) package, where can i find it ?
Thanks.
I use Lazarus 1.8.0 32/64 and FPC 3.0.3 32/64 on Linux Mint Mate 17 32/64, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs

Fred vS

  • Hero Member
  • *****
  • Posts: 1675
    • miXimum is the DJ's best friend
Re: What to install ?
« Reply #7 on: January 09, 2012, 09:53:35 pm »
I use Lazarus 1.8.0 32/64 and FPC 3.0.3 32/64 on Linux Mint Mate 17 32/64, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs

Fred vS

  • Hero Member
  • *****
  • Posts: 1675
    • miXimum is the DJ's best friend
Re: What to install ?
« Reply #8 on: April 12, 2012, 01:01:41 pm »
Hello folks.
I'm desperate  :'(
I just have done a update of Ubuntu and if i want to load my software compiled with Qt, it do not work.
Of course i have download and install :
https://launchpad.net/ubuntu/oneiric/amd64/libqt4pas5/2.1Qt4.5.3-5.1ubuntu1 but dependencies are sill missing.
Then i have install via synaptic Qt developpement tools but still some missing dependencies (for example Qtwebtoolkit).
What a hell to do Qt working...(without Lazarus installed)

My question was simple:
What must install a user (who did not install Lazarus and Qt for Lazarus) to do working a program compiled with Lazarus and Qt widgetset.

Thanks for the brave heart who can help me.
I use Lazarus 1.8.0 32/64 and FPC 3.0.3 32/64 on Linux Mint Mate 17 32/64, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs

Leledumbo

  • Hero Member
  • *****
  • Posts: 8111
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: What to install ?
« Reply #9 on: April 12, 2012, 03:36:45 pm »
A proper Qt library installation (this depends on distro, find it out in your package manager) + libQt4Pas (in ubuntu repo, it's already available and AFAIK lists all of its dependencies correctly) should do it.

zeljko

  • Hero Member
  • *****
  • Posts: 1080
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: What to install ?
« Reply #10 on: April 12, 2012, 07:39:57 pm »
One more thing: I've installed ubuntu 11.10 inside vmware, and libqt4pas provided by ubuntu crashes any qtlcl app, so I have to compile it by myself, and then it works ok.