Recent

Author Topic: ant debug failed  (Read 4572 times)

anta40

  • New Member
  • *
  • Posts: 26
ant debug failed
« on: March 17, 2012, 04:15:15 am »
I just built lazarus (the trunk version), and also the androidlcltest as well.

This are the messages:
Quote
/usr/lib/lazarus/lcl/interfaces/customdrawn/customdrawnwinapi_android.inc(3579,3) Note: Local variable "R" not used
/usr/lib/lazarus/lcl/interfaces/customdrawn/customdrawnlclintf_android.inc(277,23) Warning: Function result does not seem to be set
"Compiling package LCL 1.0.1" completed
Options changed, recompiling clean with -B
secondform.pas(33,63) Hint: Parameter "Shift" not used
secondform.pas(34,61) Hint: Parameter "Shift" not used
secondform.pas(42,37) Hint: Parameter "AMessage" not used
secondform.pas(9,11) Hint: Unit "ComCtrls" not used in secondform
mainform.pas(60,25) Hint: Parameter "Button" not used
mainform.pas(60,47) Hint: Parameter "Shift" not used
mainform.pas(61,25) Hint: Parameter "Shift" not used
mainform.pas(62,23) Hint: Parameter "Button" not used
mainform.pas(62,45) Hint: Parameter "Shift" not used
mainform.pas(28,48) Hint: Parameter "Button" not used
mainform.pas(29,7) Hint: Parameter "Shift" not used
mainform.pas(30,48) Hint: Parameter "Shift" not used
mainform.pas(32,46) Hint: Parameter "Button" not used
mainform.pas(33,7) Hint: Parameter "Shift" not used
mainform.pas(36,62) Hint: Parameter "Shift" not used
mainform.pas(39,60) Hint: Parameter "Shift" not used
mainform.pas(45,46) Hint: Parameter "Shift" not used
mainform.pas(9,17) Hint: Unit "Arrow" not used in mainform
Project "androidlcltest" successfully built

The next step is modify local.properties, This is mine:
Code: [Select]
# This file is automatically generated by Android Tools.
# Do not modify this file -- YOUR CHANGES WILL BE ERASED!
#
# This file must *NOT* be checked in Version Control Systems,
# as it contains information specific to your local configuration.

# location of the SDK. This is only used by Ant
# For customization when using a Version Control System, please read the
# header note.
sdk.dir=/opt/android-sdk

Then I ran "ant debug". I got this:
Quote
Buildfile: /home/anta40/lazarus-svn/trunk/examples/androidlcl/android/build.xml

BUILD FAILED
/home/anta40/lazarus-svn/trunk/examples/androidlcl/android/build.xml:83: Cannot find /opt/android-sdk/ /tools/ant/build.xml imported from /home/anta40/lazarus-svn/trunk/examples/androidlcl/android/build.xml

Total time: 0 seconds

Cannot find /opt/android-sdk? Hmm strange. Now I'm confused.  %)

truetom

  • Jr. Member
  • **
  • Posts: 72
    • http://sourceforge.net/projects/laz4android/
Re: ant debug failed
« Reply #1 on: March 17, 2012, 05:44:42 am »
Hello,please change sdk.dir  to your android sdk directory.sorry for my bad english!
laz4android : a Lazarus for Android Package.
http://sourceforge.net/projects/laz4android/

anta40

  • New Member
  • *
  • Posts: 26
Re: ant debug failed
« Reply #2 on: April 02, 2012, 01:06:16 pm »
Hello,please change sdk.dir  to your android sdk directory.sorry for my bad english!

Uhmm... I guess I already changed the sdk.dir
Code: [Select]
sdk.dir=/opt/android-sdk
Like that, right?

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7503
Re: ant debug failed
« Reply #3 on: April 02, 2012, 01:32:40 pm »
Hello,please change sdk.dir  to your android sdk directory.sorry for my bad english!

Uhmm... I guess I already changed the sdk.dir
Code: [Select]
sdk.dir=/opt/android-sdk
Like that, right?

Look at the spelling of the error:

Quote
/opt/android-sdk/ /tools/ant/build.xml

Notice the / / ?  Seems that ant is a bit braindead, and takes a trailing space in the configuration file to be part of the PATH. Correct that, make sure that on the sdk.dir= line there is no trailing space.