Recent

Author Topic: [SOLVED] Quais dependências para o Free Pascal?  (Read 3934 times)

aguiar

  • New Member
  • *
  • Posts: 47
  • Ubuntu 14.04
[SOLVED] Quais dependências para o Free Pascal?
« on: March 11, 2012, 02:56:55 pm »
Estou tentando instalar a versão 2.6.0.1 (atual) do Free Pascal no Ubuntu (nova instalação) com o comando no diretório onde estão os pacotes .DEB:

sudo dpkg -i *.deb

resultado:

Code: [Select]
Selecionando pacote previamente não selecionado fpc.
(Lendo banco de dados ... 140205 arquivos e diretórios atualmente instalados).
Desempacotando fpc (de fpc_2.6.0-1_all.deb) ...
...

[b]Os Erros:[/b]

dpkg: problemas de dependência impedem a configuração de fp-units-gfx-2.6.0:
 fp-units-gfx-2.6.0 depende de libsvga1-dev; porém:
  Pacote libsvga1-dev não está instalado.
dpkg: erro processando fp-units-gfx-2.6.0 (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de fp-units-gtk-2.6.0:
 fp-units-gtk-2.6.0 depende de libgtk2.0-dev; porém:
  Pacote libgtk2.0-dev não está instalado.
dpkg: erro processando fp-units-gtk-2.6.0 (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de fp-units-multimedia-2.6.0:
 fp-units-multimedia-2.6.0 depende de libogg-dev; porém:
  Pacote libogg-dev não está instalado.
 fp-units-multimedia-2.6.0 depende de libvorbis-dev; porém:
  Pacote libvorbis-dev não está instalado.
 fp-units-multimedia-2.6.0 depende de a52dec-dev; porém:
  Pacote a52dec-dev não está instalado.
 fp-units-multimedia-2.6.0 depende de libdts-dev; porém:
  Pacote libdts-dev não está instalado.
 fp-units-multimedia-2.6.0 depende de libmad0-dev; porém:
  Pacote libmad0-dev não está instalado.
 fp-units-multimedia-2.6.0 depende de libmodplug-dev; porém:
  Pacote libmodplug-dev não está instalado.
 fp-units-multimedia-2.6.0 depende de libsdl-mixer1.2-dev; porém:
  Pacote libsdl-mixer1.2-dev não está instalado.
dpkg: erro processando fp-units-multimedia-2.6.0 (--install):
 problemas de dependência - deixando desconfigurado
Configurando fp-units-rtl-2.6.0 (2.6.0-1) ...
Configurando fp-utils-2.6.0 (2.6.0-1) ...
update-alternatives: usando /usr/lib/fpc/2.6.0 para fornecer /usr/lib/fpc/default (fp-utils) em modo automático.
dpkg: problemas de dependência impedem a configuração de fpc-2.6.0:
 fpc-2.6.0 depende de fp-units-gtk-2.6.0 (>= 2.6.0-1); porém:
  Pacote fp-units-gtk-2.6.0 não está configurado ainda.
 fpc-2.6.0 depende de fp-units-gfx-2.6.0 (>= 2.6.0-1); porém:
  Pacote fp-units-gfx-2.6.0 não está configurado ainda.
 fpc-2.6.0 depende de fp-units-multimedia-2.6.0 (>= 2.6.0-1); porém:
  Pacote fp-units-multimedia-2.6.0 não está configurado ainda.
dpkg: erro processando fpc-2.6.0 (--install):
 problemas de dependência - deixando desconfigurado
Configurando fp-compiler-2.6.0 (2.6.0-1) ...
update-alternatives: usando /usr/bin/fpc-2.6.0 para fornecer /usr/bin/fpc (fpc) em modo automático.
update-alternatives: usando /usr/bin/fpc-2.6.0 para fornecer /usr/bin/pc (pc) em modo automático.
update-alternatives: usando /etc/fpc-2.6.0.cfg para fornecer /etc/fpc.cfg (fpc.cfg) em modo automático.
Configurando fpc-source (2.6.0-1) ...
Configurando fp-ide-2.6.0 (2.6.0-1) ...
Configurando fp-units-base-2.6.0 (2.6.0-1) ...
Configurando fp-units-db-2.6.0 (2.6.0-1) ...
Configurando fp-units-fcl-2.6.0 (2.6.0-1) ...
Configurando fp-units-fv-2.6.0 (2.6.0-1) ...
dpkg: problemas de dependência impedem a configuração de fp-units-gfx:
 fp-units-gfx depende de fp-units-gfx-2.6.0 (= 2.6.0-1); porém:
  Pacote fp-units-gfx-2.6.0 não está configurado ainda.
dpkg: erro processando fp-units-gfx (--install):
 problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de fp-units-gnome1-2.6.0:
 fp-units-gnome1-2.6.0 depende de fp-units-gtk-2.6.0 (= 2.6.0-1); porém:
  Pacote fp-units-gtk-2.6.0 não está configurado ainda.
dpkg: erro processando fp-units-gnome1-2.6.0 (--install):
 problemas de dependência - deixando desconfigurado
Configurando fp-units-gtk2-2.6.0 (2.6.0-1) ...
dpkg: problemas de dependência impedem a configuração de fp-units-gtk:
 fp-units-gtk depende de fp-units-gtk-2.6.0 (= 2.6.0-1); porém:
  Pacote fp-units-gtk-2.6.0 não está configurado ainda.
dpkg: erro processando fp-units-gtk (--install):
 problemas de dependência - deixando desconfigurado
Configurando fp-units-i386-2.6.0 (2.6.0-1) ...
Configurando fp-units-math-2.6.0 (2.6.0-1) ...
Configurando fp-units-misc-2.6.0 (2.6.0-1) ...
dpkg: problemas de dependência impedem a configuração de fp-units-multimedia:
 fp-units-multimedia depende de fp-units-multimedia-2.6.0 (= 2.6.0-1); porém:
  Pacote fp-units-multimedia-2.6.0 não está configurado ainda.
dpkg: erro processando fp-units-multimedia (--install):
 problemas de dependência - deixando desconfigurado
Configurando fp-units-net-2.6.0 (2.6.0-1) ...
Configurando fp-units-rtl (2.6.0-1) ...
dpkg: problemas de dependência impedem a configuração de fpc:
 fpc depende de fpc-2.6.0 (= 2.6.0-1); porém:
  Pacote fpc-2.6.0 não está configurado ainda.
dpkg: erro processando fpc (--install):
 problemas de dependência - deixando desconfigurado
Configurando fp-units-base (2.6.0-1) ...
Configurando fp-units-db (2.6.0-1) ...
Configurando fp-units-fcl (2.6.0-1) ...
Configurando fp-units-fv (2.6.0-1) ...
dpkg: problemas de dependência impedem a configuração de fp-units-gnome1:
 fp-units-gnome1 depende de fp-units-gnome1-2.6.0 (= 2.6.0-1); porém:
  Pacote fp-units-gnome1-2.6.0 não está configurado ainda.
dpkg: erro processando fp-units-gnome1 (--install):
 problemas de dependência - deixando desconfigurado
Configurando fp-units-gtk2 (2.6.0-1) ...
Configurando fp-units-i386 (2.6.0-1) ...
Configurando fp-units-math (2.6.0-1) ...
Configurando fp-units-misc (2.6.0-1) ...
Configurando fp-units-net (2.6.0-1) ...
Processando gatilhos para man-db ...
Configurando fp-ide (2.6.0-1) ...
Configurando fp-utils (2.6.0-1) ...
Processando gatilhos para doc-base ...
Processing 2 added doc-base file(s)...
Registering documents with scrollkeeper...
Configurando fp-compiler (2.6.0-1) ...
Configurando fp-docs (2.6.0-1) ...
Erros foram encontrados durante o processamento de:
 fp-units-gfx-2.6.0
 fp-units-gtk-2.6.0
 fp-units-multimedia-2.6.0
 fpc-2.6.0
 fp-units-gfx
 fp-units-gnome1-2.6.0
 fp-units-gtk
 fp-units-multimedia
 fpc
 fp-units-gnome1
« Last Edit: March 11, 2012, 03:43:00 pm by aguiar »

aguiar

  • New Member
  • *
  • Posts: 47
  • Ubuntu 14.04
[SOLVED] Re: Quais dependências para o Free Pascal?
« Reply #1 on: March 11, 2012, 03:41:05 pm »
Solucionado!

Abri o synaptic, apareceu uma mensagem avisando sobre pacotes quebrados, cliquei no menu Editar >> Corrigir pacotes quebrados e aceitei.
Foram baixados vários pacotes, são eles:

Code: [Select]
debhelper (versão 8.0.0ubuntu1) será instalado
esound-clients (versão 0.2.41-7) será instalado
esound-common (versão 0.2.41-7) será instalado
gettext (versão 0.18.1.1-1ubuntu2) será instalado
html2text (versão 1.3.2a-15) será instalado
intltool-debian (versão 0.35.0+20060710.1) será instalado
liba52-0.7.4-dev (versão 0.7.4-14ubuntu1) será instalado
libaa1-dev (versão 1.4p5-38build1) será instalado
libasound2-dev (versão 1.0.23-1ubuntu2.1) será instalado
libatk1.0-dev (versão 1.32.0-0ubuntu1) será instalado
libaudio-dev (versão 1.9.2-3) será instalado
libaudio2 (versão 1.9.2-3) será instalado
libaudiofile-dev (versão 0.2.6-8ubuntu1) será instalado
libaudiofile0 (versão 0.2.6-8ubuntu1) será instalado
libavahi-client-dev (versão 0.6.27-2ubuntu3.1) será instalado
libavahi-common-dev (versão 0.6.27-2ubuntu3.1) será instalado
libcaca-dev (versão 0.99.beta17-1) será instalado
libcairo-gobject2 (versão 1.10.0-1ubuntu3) será instalado
libcairo2-dev (versão 1.10.0-1ubuntu3) será instalado
libdbus-1-dev (versão 1.4.0-0ubuntu1.3) será instalado
libdca-dev (versão 0.0.5-3) será instalado
libdrm-dev (versão 2.4.21-1ubuntu2.1) será instalado
libdts-dev (versão 0.0.5-3) será instalado
libesd0 (versão 0.2.41-7) será instalado
libesd0-dev (versão 0.2.41-7) será instalado
libexpat1-dev (versão 2.0.1-7ubuntu1) será instalado
libfontconfig1-dev (versão 2.8.0-2ubuntu1) será instalado
libfreetype6-dev (versão 2.4.2-2ubuntu0.3) será instalado
libgdk-pixbuf2.0-dev (versão 2.22.0-0ubuntu1) será instalado
libgl1-mesa-dev (versão 7.9~git20100924-0ubuntu2) será instalado
libglib2.0-bin (versão 2.26.1-0ubuntu1) será instalado
libglib2.0-dev (versão 2.26.1-0ubuntu1) será instalado
libglu1-mesa-dev (versão 7.9~git20100924-0ubuntu2) será instalado
libgtk2.0-dev (versão 2.22.0-0ubuntu1) será instalado
libice-dev (versão 2:1.0.6-1) será instalado
libkms1 (versão 2.4.21-1ubuntu2.1) será instalado
libmad0-dev (versão 0.15.1b-4ubuntu2) será instalado
libmail-sendmail-perl (versão 0.79.16-1) será instalado
libmikmod2 (versão 3.1.11-a-6.3) será instalado
libmikmod2-dev (versão 3.1.11-a-6.3) será instalado
libmodplug-dev (versão 1:0.8.8.1-1ubuntu1.3) será instalado
libncurses5-dev (versão 5.7+20100626-0ubuntu1) será instalado
libogg-dev (versão 1.2.0~dfsg-1) será instalado
libpango1.0-dev (versão 1.28.2-0ubuntu1.1) será instalado
libpixman-1-dev (versão 0.18.4-1) será instalado
libpng12-dev (versão 1.2.44-1ubuntu0.2) será instalado
libpthread-stubs0 (versão 0.3-2) será instalado
libpthread-stubs0-dev (versão 0.3-2) será instalado
libpulse-dev (versão 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1) será instalado
libsdl-mixer1.2 (versão 1.2.8-6build1) será instalado
libsdl-mixer1.2-dev (versão 1.2.8-6build1) será instalado
libsdl1.2-dev (versão 1.2.14-6ubuntu3) será instalado
libslang2-dev (versão 2.2.2-4ubuntu1) será instalado
libsm-dev (versão 2:1.1.1-1) será instalado
libsmpeg-dev (versão 0.4.5+cvs20030824-2.2) será instalado
libsmpeg0 (versão 0.4.5+cvs20030824-2.2) será instalado
libsvga1 (versão 1:1.4.3-29) será instalado
libsvga1-dev (versão 1:1.4.3-29) será instalado
libsys-hostname-long-perl (versão 1.4-2) será instalado
libunistring0 (versão 0.9.3-1) será instalado
libvorbis-dev (versão 1.3.1-1ubuntu0.1) será instalado
libx11-dev (versão 2:1.3.3-3ubuntu1) será instalado
libxau-dev (versão 1:1.0.6-1) será instalado
libxcb-render0-dev (versão 1.6-1) será instalado
libxcb-shm0-dev (versão 1.6-1) será instalado
libxcb1-dev (versão 1.6-1) será instalado
libxcomposite-dev (versão 1:0.4.2-1) será instalado
libxcursor-dev (versão 1:1.1.10-2) será instalado
libxdamage-dev (versão 1:1.1.3-1) será instalado
libxdmcp-dev (versão 1:1.0.3-2) será instalado
libxext-dev (versão 2:1.1.2-1) será instalado
libxfixes-dev (versão 1:4.0.5-1) será instalado
libxft-dev (versão 2.1.14-2ubuntu1) será instalado
libxi-dev (versão 2:1.3-4) será instalado
libxinerama-dev (versão 2:1.1-3) será instalado
libxrandr-dev (versão 2:1.3.0-3) será instalado
libxrender-dev (versão 1:0.9.6-1) será instalado
libxt-dev (versão 1:1.0.7-1) será instalado
mesa-common-dev (versão 7.9~git20100924-0ubuntu2) será instalado
po-debconf (versão 1.0.16) será instalado
x11proto-composite-dev (versão 1:0.4.1-1) será instalado
x11proto-core-dev (versão 7.0.17-1) será instalado
x11proto-damage-dev (versão 1:1.2.0-1) será instalado
x11proto-fixes-dev (versão 1:4.1.1-2) será instalado
x11proto-input-dev (versão 2.0-2) será instalado
x11proto-kb-dev (versão 1.0.4-1) será instalado
x11proto-randr-dev (versão 1.3.1-1) será instalado
x11proto-render-dev (versão 2:0.11-1) será instalado
x11proto-xext-dev (versão 7.1.1-2) será instalado
x11proto-xinerama-dev (versão 1.2-2) será instalado
xtrans-dev (versão 1.2.5-1) será instalado
zlib1g-dev (versão 1:1.2.3.4.dfsg-3ubuntu1) será instalado

Então, são estes acima a dependência para se instalar o Free Pascal 2.6.0.1.
Refiz a compilação do Free Pascal e deu tudo certo, depois baixei o Lazarus (via svn), compilei com make clean all e tudo funcionou corretamente, o Lazarus foi instalado corretamente.

Fica aqui registrado para futuros usuários com o mesmo problema.
Só uma informação: Ubuntu Linux 10.10

 

TinyPortal © 2005-2018