Recent

Author Topic: KOL-CE cannot compile  (Read 8703 times)

christensen

  • Full Member
  • ***
  • Posts: 126
KOL-CE cannot compile
« on: February 27, 2012, 05:43:46 pm »
Hi,

I'm trying to install KOL-CE from svn: https://kol-ce.svn.sourceforge.net/svnroot/kol-ce/trunk but i cannot compile, this error i get:

Quote
C:\lazarus\components\kol-ce\mck\mckToolbarEditor.pas(803,59) Error: Identifier not found "GetLookupRootForComponent"
C:\lazarus\components\kol-ce\mck\mckToolbarEditor.pas(995,4) Fatal: There were 1 errors compiling module, stopping

My system:
Dell Latitude D620,T2300 1.66Mhz, Windows XP PRO SP3 32Bit, Lazarus 0.9.30.2, FPC 2.4.4 &
Lazarus-0.9.30.2-fpc-2.4.4-cross-arm-wince-win32
Lazarus 1.4.4, FPC 2.6.4, Windows 7 64bit, AMD Athlon 7750 black edition, Asus M3N78-CM
Lenovo L540 i7-4702MQ, Windows 10 x64,Lazarus 1.6.2,FPC 3.0

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7071
Re: KOL-CE cannot compile
« Reply #1 on: February 27, 2012, 09:27:11 pm »
Sounds like a KOL problem (like e.g. not having IFDEF VER related ifdefs for more recent versions), report it on the KOL site.

Dibo

  • Hero Member
  • *****
  • Posts: 1045
Re: KOL-CE cannot compile
« Reply #2 on: September 09, 2012, 03:50:28 pm »
Sorry for digging old topic, but I created patch for this:
http://sourceforge.net/tracker/?func=detail&atid=925375&aid=3565831&group_id=188451

Now KOL-CE can be installed on lazarus 1.0, but events doesn't work on KOL controls. I do not have the knowledge to fix it. Here is description of bug:
http://sourceforge.net/tracker/?func=detail&aid=3565830&group_id=188451&atid=925373

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7071
Re: KOL-CE cannot compile
« Reply #3 on: September 10, 2012, 08:02:26 pm »
Is KOL still maintained at all? Haven't heard about it in ages.

Dibo

  • Hero Member
  • *****
  • Posts: 1045
Re: KOL-CE cannot compile
« Reply #4 on: September 10, 2012, 08:38:33 pm »
BTW: How KOL works? Is this just very light wrapper for winapi controls? Can something similar done for e.g linux?

nhsoft

  • New member
  • *
  • Posts: 7
Re: KOL-CE cannot compile
« Reply #5 on: October 25, 2013, 06:03:06 am »
I have apply the patch for lazarus v1.0.x, now i create new kol-ce project, when lazarus compiling, the ide throw follow error message:

Quote
unit1.pas(38,2) Fatal: It is not possible to include a file that starts with an UTF-8 BOM in a module that uses a different code page

how to fix the error, thanks.

nhsoft

  • New member
  • *
  • Posts: 7
Re: KOL-CE cannot compile
« Reply #6 on: October 25, 2013, 06:05:07 am »
the patch add new line in MirrorKOLPackage.lpk

Quote
<UseAnsiStrings Value="False"/>

the error relate with the option? my windows language is simple chinese.