Recent

Author Topic: "Failed to open Gecko/XULRunner browser-window" from WebDesign package example.  (Read 6142 times)

touchring

  • Full Member
  • ***
  • Posts: 174
Hi, I've encountered this error, tried for half a day, searched the forum but can't find a solution.

1. I'm using Laz 0.9.31, FPC 2.5.1, Windows 7, 64 bit, used fppkg.exe to download Gecko, WebDesign and Embweb package files, compiled and installed them.

2. I've also downloaded Xulrunner folder from:  http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/2010/05/2010-05-17-03-mozilla-1.9.2/xulrunner-1.9.2.5pre.en-US.win32.zip, unzip and extract the XULrunner folder to the same folder as Lazarus.

3. I compiled gbrowser example in Gecko package download, copied the file to XULrunner folder, and it works ok.

4. But when I try to open any of the WebDesign example, e.g. HelloWorld, I get the following error.

"Failed to open Gecko/XULRunner browser-window.

Make sure Gecko/XULRunner is installed.  If you are sure you have it installed, check the filename of the XPCOM library in the environment settings. (Environment -> Options -> Webdesign)

I tried to set XPCOM library to "xpcom.dll" and also to the full path, but both doesn't work.

I've also tried copying XULRunner folder all over the place including the example folder but to no avail.  What else do I need to do?  Thanks.

touchring

  • Full Member
  • ***
  • Posts: 174
Any thoughts?  Or is there an alternative editor for web?  Thanks.   :)
« Last Edit: January 28, 2012, 05:07:08 pm by touchring »

LA.Center

  • Full Member
  • ***
  • Posts: 244
    • LA.Center
Can you use Laz/Qt by any chance? In Laz/Qt you can use QWebKit, I have attached a wrapper for it if you want.

Just remove ED_QT defs and aeditions.inc

Cheers

fabienwang

  • Sr. Member
  • ****
  • Posts: 449
  • Lazarus is the best
    • My blog
Hello, your u_webkit works great :) thanks.
But instead of removing ED_QT directives, replace them by LCLQt.

Take this version:
I'm using Arch Linux.
Known for: CPickSniff, OpenGrabby
Contributed to: LazPaint

touchring

  • Full Member
  • ***
  • Posts: 174
Can you use Laz/Qt by any chance? In Laz/Qt you can use QWebKit, I have attached a wrapper for it if you want.

Just remove ED_QT defs and aeditions.inc

Cheers

Thanks, I'm trying the demos in WebDesign package, how does u_webkit.pas work?   :-\

fabienwang

  • Sr. Member
  • ****
  • Posts: 449
  • Lazarus is the best
    • My blog
Can you use Laz/Qt by any chance? In Laz/Qt you can use QWebKit, I have attached a wrapper for it if you want.

Just remove ED_QT defs and aeditions.inc

Cheers

Thanks, I'm trying the demos in WebDesign package, how does u_webkit.pas work?   :-\

It's a binding to QtWebkit component from Qt Framework. (so it only works if your project compiles in Qt
I'm using Arch Linux.
Known for: CPickSniff, OpenGrabby
Contributed to: LazPaint