Recent

Author Topic: Zeoslib - can't compile and install  (Read 6327 times)

M[a]nny

  • Full Member
  • ***
  • Posts: 122
  • Dreamer
Zeoslib - can't compile and install
« on: December 07, 2011, 11:20:32 am »
Hi,

i am using Zeoslib 6.6.6 and Lazarus IDE v0.9.31 build 34014, FPC 2.5.1 on Windows 7. When i download same Lazarus version but FPC 2.4.4, all works OK.

But it doesn't work on FPC 2.5.1 - it returns this error compilation message:
Code: [Select]
C:\lazarus\komponenty\zeoslib\src\core\ZClasses.pas(84,22) Error: No matching implementation for interface method "IUnknown.QueryInterface(constref TGuid,out <Formal type>):LongInt; StdCall;" found

on the line 84 is:
Code: [Select]
  TContainedObject = class(TAggregatedObject, IInterface)
Can anybody help me? It seems that FPC 2.5.1 has changed syntax in some way.
Bad news: Time flies.
Good news: You are the pilot.

Don't try to be perfect, just be unique.

ludob

  • Hero Member
  • *****
  • Posts: 1173
Re: Zeoslib - can't compile and install
« Reply #1 on: December 07, 2011, 12:07:42 pm »
IUnknown.QueryInterface has changed. It uses now constref iid:tguid. Before it was const iid:tguid.

CodeTyphon has updated zeoslib 6.6.6 for use with 2.5.1. I'm using that version without any problem with lazarus svn and fpc.

M[a]nny

  • Full Member
  • ***
  • Posts: 122
  • Dreamer
Re: Zeoslib - can't compile and install
« Reply #2 on: December 07, 2011, 01:02:11 pm »
Who is CodeTyphon and where can i find that version, please?
Bad news: Time flies.
Good news: You are the pilot.

Don't try to be perfect, just be unique.

ludob

  • Hero Member
  • *****
  • Posts: 1173
Re: Zeoslib - can't compile and install
« Reply #3 on: December 07, 2011, 01:43:34 pm »

ghieber

  • New member
  • *
  • Posts: 5
Re: Zeoslib - can't compile and install
« Reply #4 on: January 24, 2012, 03:27:47 am »
Exactly the same happens under FPC 2.6.0. I will try the mentioned fix and report.

I Installed the ZeosLib version from CodeTyphoon, and it works.

I don't know how "alive" the ZeosLib project still is, but an official fix would be great!
« Last Edit: January 26, 2012, 12:31:13 am by ghieber »

IndianaJones

  • Hero Member
  • *****
  • Posts: 509
Re: Zeoslib - can't compile and install
« Reply #5 on: January 27, 2012, 01:23:18 pm »

Revision 967 works with FPC2.6.0 for Mac OS X 10.6

shiruba

  • New Member
  • *
  • Posts: 10
    • Galapagos Software
Re: Zeoslib - can't compile and install
« Reply #6 on: February 22, 2012, 06:48:57 am »
Revision 967? Where? CodeTyphoon, or the official project page on SourceForge.  I downloaded 7.0.0 alpha from there, and the same issue is still there. 

Surely the code modification required should be minor - if someone could just post it...
Galapagos Software - Lazarus Code

IndianaJones

  • Hero Member
  • *****
  • Posts: 509
Re: Zeoslib - can't compile and install
« Reply #7 on: February 22, 2012, 07:55:15 am »

Hi shiruba, here is the detail of the svn revision infos.

Path: zeoslib
URL: https://zeoslib.svn.sourceforge.net/svnroot/zeoslib
Repository Root: https://zeoslib.svn.sourceforge.net/svnroot/zeoslib
Repository UUID: af792bfc-cb77-4cd8-95e0-e39f8be9f718
Revision: 967
Node Kind: directory
Schedule: normal
Last Changed Author: ciccio20
Last Changed Rev: 967
Last Changed Date: 2012-01-18 18:23:44 +0200 (Wed, 18 Jan 2012)

Also you have to modify plain files for the dynlib. Here is the path you can reach in
/zeoslib/trunk/src/plain
Thanks.

 

TinyPortal © 2005-2018