Forum > macOS / Mac OS X

problem installing the socket component

(1/2) > >>

I tried to install the socket component on lazarus 9.10 for Mac OS X and i go this errors:

/usr/local/share/lazarus/components/sockets/SocketClient.pas(265,33) Error: Illegal qualifier
/usr/local/share/lazarus/components/sockets/SocketClient.pas(265,55) Error: Illegal qualifier
/usr/local/share/lazarus/components/sockets/SocketClient.pas(265,77) Error: Illegal qualifier
/usr/local/share/lazarus/components/sockets/SocketClient.pas(265,99) Error: Illegal qualifier
/usr/local/share/lazarus/components/sockets/SocketClient.pas(505,23) Hint: Local variable "c" does not seem to be initialized
/usr/local/share/lazarus/components/sockets/SocketClient.pas(534) Fatal: There were 4 errors compiling module, stopping

Can someone explain me what's going wrong ?

Vincent Snijders:
See also this forum post on the lazarus-ccr forum.

It was tested on win32, but maybe this fixes the issue on Mac OS X too.

If it works, please send a mail to author of the component, so that he can update it.
You can find his details on the Sockets wiki page.

Thanks you it works but now I got another problem. If I click on the install button it rebuild lazarus and I got this error:

Fatal: Can't find unit AllIDEIntf

Of course I check, and this unit exists

So I decided to rebuild it "manualy" using the "Rebuild lazarus" command in the "Tools" menu. And now I got another error:

/usr/local/share/lazarus/ideintf/ComponentReg.pas(1,1) Fatal: Can't find unit LazarusPackageIntf

Thanks for all,


Vincent Snijders:
My first guess is that the compiler selected in Envirionment -> Envirionment Options -> Files is not the same as the compiler used to compile these units (and the current lazarus itself). Can you check that.

If that is the case, you can either:
- select the compiler used for lazarus in the environment options
- rebuild lazarus completely, enter the configure build lazarus dialog and set IDE and everything above to clean+build.

The complier in the Environement option is "ppcppc". I tried to rebuild completly, no problems occurs durring the building but now i go this error when I trying to launch Lazarus:

Threading has been used before cthreads was initialized.
Make cthreads one of the first units in your uses clause.
Runtime error 211 at $0066E188
  $000023D8  main,  line 63 of lazarus.pp
  $00001F78  _start,  of /SourceCache/Csu/Csu-57.0.82//SourceCache/Csu/Csu-57.0.82/crt.c
  $00001E1C of SynEditTypes.pp

Sorry fo wasting your time.



[0] Message Index

[#] Next page

Go to full version