Recent

Author Topic: Virtualtreeview install woes  (Read 4996 times)

snorkel

  • Hero Member
  • *****
  • Posts: 810
Virtualtreeview install woes
« on: October 03, 2011, 02:28:00 am »
Any get virtualtreeview to work in Lazarus?  I can't get it to compile into the ide for nothing, keep getting a in the
required lcl extensions package.

QWidget_scroll(TQtWidget(hWnd).Widget, XAmount, YAmount, lpRect);

/home/tcaduto/components/lclextensions-0.3.0/include/qt/delphicompat.inc(192,18) Error: Illegal type conversion: "LongInt" to "TQtWidget"

My version of Lazarus as reported from the about dialog is: 0.9.31 and I am runing on Chakra Linux x86_64






***Snorkel***
If I forget, I always use the latest stable 32bit version of Lazarus and FPC. At the time of this signature that is Laz 2.06 and FPC 3.0.4
OS: Windows 10 64 bit

IPguy

  • Sr. Member
  • ****
  • Posts: 385
Re: Virtualtreeview install woes
« Reply #1 on: October 10, 2011, 02:39:27 am »
Are you using the version of VTV from the SVN / components / virtualtreeview-new folder?
I've not had any trouble getting that to install and work for the last year or so.

JD

  • Hero Member
  • *****
  • Posts: 1767
Re: Virtualtreeview install woes
« Reply #2 on: October 11, 2011, 10:56:08 am »
VirtualTreeView works on Linux (Ubuntu & Mint) for me. It is dependent on LCL Extensions and Multilog. You need to compile/install the two packages to be able to install it on Windows or on Linux.

Cheers,

JD
Windows (10, 7) - Lazarus 2.0.6/FPC 3.2, Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

Shebuka

  • Sr. Member
  • ****
  • Posts: 422
Re: Virtualtreeview install woes
« Reply #3 on: October 11, 2011, 11:56:07 am »
VirtualTreeView works on Linux (Ubuntu & Mint) for me. It is dependent on LCL Extensions and Multilog. You need to compile/install the two packages to be able to install it on Windows or on Linux.

Cheers,

JD

I'm using SVN version and need only lclextensions 0.4 under Carbon Mac OS X (and i have no multilog in installed/available packages).
Also i'v managed to compile it with Qt, but it has strange behavior with status icons.