Recent

Author Topic: LazReport Install Errors  (Read 20734 times)

Anonymous

  • Guest
RE: Re: RE: Re: RE: Re: RE: LazReport Install Errors
« Reply #15 on: November 14, 2005, 12:36:39 am »
@Vincent thank you.
I'm trying Lazarus-0.9.11-beta, and lazreport-20050605.tar.gz. I'm getting the same error. But when I updated code, then all works fine.
Thanks.

Anonymous

  • Guest
RE: Re: RE: Re: RE: Re: RE: LazReport Install Errors
« Reply #16 on: December 30, 2005, 04:49:57 am »
I have a problem when i'm using lazreport. When I'm preview my report it's ok, but if i clik print button and ok, i'll have an error that says ' Illegal character in format string'.
I'm using  lazreport-20050605.tar.gz.

jesusr

  • Sr. Member
  • ****
  • Posts: 470
Re: RE: Re: RE: Re: RE: Re: RE: LazReport Install Errors
« Reply #17 on: December 30, 2005, 07:42:44 am »
Quote from: "Anonymous"
I have a problem when i'm using lazreport. When I'm preview my report it's ok, but if i clik print button and ok, i'll have an error that says ' Illegal character in format string'.
I'm using  lazreport-20050605.tar.gz.

It would be helpful to know on what file and line of code the error happens. Anyway the package has not been updated in some time, and might have problems. Its recommended to use the most recent LazReport version (obtained from CVS) and that would also need a fairly recent Lazarus version (revision 8348 or newer would be fine) due printers and font support improvement.

Anonymous

  • Guest
RE: Re: RE: Re: RE: Re: RE: Re: RE: LazReport Install Errors
« Reply #18 on: December 30, 2005, 12:33:19 pm »
I'ml change lazreport package on XMLCfg to Laz_XMLCfg (I've  not changed, have trouble got AnsiString). I'm also removed LR_PGrid from the package (cause have an error on Line 11,34, i don't understand, why remarkable notes have an error).
I'm also use from CVS but it's same.
I'm running Fedora 3, my rpm lazarus package is fpcsrc-2.0.1-050923,fpc-2.0.1-050923, and lazarus-0.9.10-0

Anonymous

  • Guest
RE: Re: RE: Re: RE: Re: RE: Re: RE: LazReport Install Errors
« Reply #19 on: December 31, 2005, 01:37:10 am »
I'm change lazreport package on XMLCfg to Laz_XMLCfg (If not changed, have trouble got AnsiString). I'm also changed in LR_Class in procedure or variable DoFunction in var p1,p2,p3 from Variant to String (if not changed, have an error int trim(p1),trim(p2),trim(p3)) and removed LR_PGrid from the package (cause have an error on Line 11,34, i don't understand, why remarkable notes have an error).
I'm also use from CVS but it's same.
I'm running Fedora 3, my rpm lazarus package is fpcsrc-2.0.1-050923,fpc-2.0.1-050923, and lazarus-0.9.10-0

Anonymous

  • Guest
RE: Re: RE: Re: RE: Re: RE: LazReport Install Errors
« Reply #20 on: January 01, 2006, 09:55:53 pm »
I installed lazarus snapshot : Lazarus-0.9.11-20051226-win32.exe
and Lazreport from cvs when I compiled Lazreport component I got this error :

C:\lazarus\components\lazreport\source\LR_Intrp.pas(104,51) Error: Duplicate identifier "Value"
C:\lazarus\components\lazreport\source\LR_Intrp.pas(104,51) Hint: Identifier already defined in LR_Intrp.pas at line 51
C:\lazarus\components\lazreport\source\LR_Intrp.pas(115,3) Hint: Local variable "p" does not seem to be initialized
C:\lazarus\components\lazreport\source\LR_Intrp.pas(135,49) Error: Duplicate identifier "Value"
C:\lazarus\components\lazreport\source\LR_Intrp.pas(135,49) Hint: Identifier already defined in LR_Intrp.pas at line 51
C:\lazarus\components\lazreport\source\LR_Intrp.pas(148,31) Error: Duplicate identifier "Name"
C:\lazarus\components\lazreport\source\LR_Intrp.pas(148,31) Hint: Identifier already defined in LR_Intrp.pas at line 52
C:\lazarus\components\lazreport\source\LR_Intrp.pas(827) Fatal: There were 3 errors compiling module, stopping.

Eny one who can help me ?

Per

jesusr

  • Sr. Member
  • ****
  • Posts: 470
RE: Re: RE: Re: RE: Re: RE: LazReport Install Errors
« Reply #21 on: January 02, 2006, 10:37:39 pm »
Should be fixed in LazReport CVS