Recent

Author Topic: More tools need when Lazarus updating  (Read 3804 times)

cst_zf

  • New Member
  • *
  • Posts: 14
More tools need when Lazarus updating
« on: September 20, 2011, 01:44:34 pm »
When I update Lazarus from 0.9.28 to 0.9.30, there're some things make me unhappy.
First, I must install the packages such as lNet again.
Second, old version of fpc is not uninstalled by the installer and Lazarus 0.9.30 cannot find the correct fpc by itself.

When I update from 0.9.22 to 0.9.26, there is another trouble.
TForm added a property and that makes every lfm created in 0.9.22 need modified in 0.9.26

JD

  • Hero Member
  • *****
  • Posts: 1763
Re: More tools need when Lazarus updating
« Reply #1 on: September 20, 2011, 03:19:38 pm »
Reinstalling components is something that is common when updating Lazarus. I don't think it is a problem because code updates are necessary for compatibility reasons, introducing new features and for correcting bugs.

I would advise you to follow the Lazarus release cycle closely if frequent changes bother you. The current version is 0.9.30 with free pascal compiler 2.4.2 In addition, once you find a version of a component that works for your installation, keep it safe so that a newer version will not break your installation.

Others developers (like me) who are more adventurous prefer SVN releases.  :D
« Last Edit: September 20, 2011, 03:24:42 pm by JD »
Windows (10, 7) - Lazarus 2.0.6/FPC 3.2, Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1