Recent

Author Topic: [SOLVED] FPC 2.4.4 cannot compile fortes324forlaz  (Read 9521 times)

JD

  • Hero Member
  • *****
  • Posts: 1837
[SOLVED] FPC 2.4.4 cannot compile fortes324forlaz
« on: June 17, 2011, 06:58:14 pm »
When I try to compile fortes324forlaz, I get 3 errors

rlprinters.pas(125,56) Error: Incompatible type for arg no. 2: Got "LongWord", expected "PHANDLE"

rlprinters.pas(128,44) Error: Incompatible type for arg no. 5: Got "LongWord", expected "PDWord"

rlprinters.pas(133,58) Error: Incompatible type for arg no. 5: Got "LongWord", expected "PDWord"

on the following lines in rlprinters.pas

Code: Pascal  [Select][+][-]
  1. if not OpenPrinter(PChar(PrinterDevice.Name),hPrinter,@foodefs) then
  2.  

Code: Pascal  [Select][+][-]
  1. GetPrinter(hPrinter,2,nil,0,bytesNeeded)
  2.  

Code: Pascal  [Select][+][-]
  1. GetPrinter(hPrinter,2,pInfo,bytesNeeded,bytesNeeded)
  2.  

It compiled without problems in version 2.4.3 which afaik is almost the same as 2.4.4.  :(
« Last Edit: June 18, 2011, 10:13:16 am by JD »
Windows (10) - Lazarus 2.1/FPC 3.2 (svn 64160 built using fpcupdeluxe),
Linux Mint - Lazarus 2.1/FPC 3.2 (svn 64380 built using fpcupdeluxe),
Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

JanRoza

  • Hero Member
  • *****
  • Posts: 627
    • http://www.silentwings.nl
Re: FPC 2.4.4 cannot compile fortes324forlaz
« Reply #1 on: June 17, 2011, 07:29:59 pm »
Are you using Lazarus 0.9.31 or 0.9.30?
I'm running 0.9.30.1 with FPC 2.4.4 and FortesReport compiled without a problem.
I do know that Fortesreport didn't compile under Lazarus 0.9.31, Im not sure FortesReport is 0.9.31 ready yet, I thought Luiz recently mentioned it was strictly for Lazarus 0.9.30 for now.
(Am I correct Luiz?)
OS: Windows 10 (64 bit) / Linux Mint (64 bit)
Laz: Lazarus 2.0.12 FPC 3.2.0
       CodeTyphon 7.6 FPC 3.3.1

Zoran

  • Hero Member
  • *****
  • Posts: 1678
    • http://wiki.lazarus.freepascal.org/User:Zoran
Re: FPC 2.4.4 cannot compile fortes324forlaz
« Reply #2 on: June 17, 2011, 09:40:38 pm »
Im not sure FortesReport is 0.9.31 ready yet, I thought Luiz recently mentioned it was strictly for Lazarus 0.9.30 for now.
(Am I correct Luiz?)

No, if you are using stable Lazaruns 0.9.30, then you must use last release of fortes: http://sourceforge.net/projects/fortes4lazarus/files/fortesreport-3.24-LCL-R2.zip/download

But if you are using Lazarus from trunk, then you must use Fortes from trunk:
https://fortes4lazarus.svn.sourceforge.net/svnroot/fortes4lazarus/trunk/

Jan, don't you remember? ;D

JD

  • Hero Member
  • *****
  • Posts: 1837
Re: FPC 2.4.4 cannot compile fortes324forlaz
« Reply #3 on: June 18, 2011, 09:51:31 am »
Sorry I forgot to say that I'm using 0.9.31. I'll update my version of Fortes from trunk & try again.

Many thanks guys!
Windows (10) - Lazarus 2.1/FPC 3.2 (svn 64160 built using fpcupdeluxe),
Linux Mint - Lazarus 2.1/FPC 3.2 (svn 64380 built using fpcupdeluxe),
Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

JD

  • Hero Member
  • *****
  • Posts: 1837
Re: FPC 2.4.4 cannot compile fortes324forlaz
« Reply #4 on: June 18, 2011, 10:12:52 am »
It's fine now, thanks a lot.
Windows (10) - Lazarus 2.1/FPC 3.2 (svn 64160 built using fpcupdeluxe),
Linux Mint - Lazarus 2.1/FPC 3.2 (svn 64380 built using fpcupdeluxe),
Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

JanRoza

  • Hero Member
  • *****
  • Posts: 627
    • http://www.silentwings.nl
Re: [SOLVED] FPC 2.4.4 cannot compile fortes324forlaz
« Reply #5 on: June 18, 2011, 09:18:22 pm »
@Zoran: I hadn't forgotten but yesterday I couldn't find the old thread anywhere.
For now I'running Lazarus 0.9.30.1/FPC 244 which suites my needs perfectly.
Thanks for giving me back my memory  ;)
 
OS: Windows 10 (64 bit) / Linux Mint (64 bit)
Laz: Lazarus 2.0.12 FPC 3.2.0
       CodeTyphon 7.6 FPC 3.3.1

 

TinyPortal © 2005-2018