Forum > Networking and Web Programming

FCGI (FastCGI) step by step, using fpweb/fcl-web for Windows/Linux

<< < (9/11) > >>

but if you write like this something comes back

    $ netstat -tunlp | grep 2015

No result too.

If netstat command above shows no result, it means your application is not running. That is why Apache cannot connect to your application. You need to run application first.

I have no experience with Apache, and I can run FCGI modules on IIS - Windows 10 successfully.

Logically thinking, IIS runs FCGI program so I do not assign separate port -- I think the same applies to Apache. Separate port is necessary to run it as HTTP server, which responses directly, not via IIS or Apache. 

First, test with following main program.

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---begin   Application.Title:='fcgihellow';  { Uncomment the port setting here if you want to run the    FastCGI application stand-alone (e.g. for NGINX) }  // Application.Port:=2015; // For example    LegacyRouting:= True;    Application.Initialize;   Application.Run;end. 
In IIS, I have to set Handler Mappings --- I have to add mapping for the application program. Don't know how to do this in Apache.

Important thing is that allowPathInfo should be set TRUE. Again, no idea whether this is applicable to Apache.

But as I posted in other posts, Free Pascal fCGI model is not perfect --- I believe it has some problem in memory management. (the author acknowledges this). 

Anyway please let me know your result. I'd like to have as many developers of Lazarus webserver as possible.^^

I have deleted link to fastcgi module.

It does always no result.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version