Recent

Author Topic: 0.9.1 installer/binary  (Read 18180 times)

neli

  • Administrator
  • Jr. Member
  • *
  • Posts: 86
0.9.1 installer/binary
« Reply #15 on: February 22, 2004, 04:41:14 pm »
I have tried to fix this, could you check if it works, BrainChemistry? Update your CVS, and try to recompile.

Micha.

BrainChemistry

  • Jr. Member
  • **
  • Posts: 65
0.9.1 installer/binary
« Reply #16 on: February 22, 2004, 08:12:59 pm »
Good work, Micha!

Now there weren't any further problems compiling lazarus.

Thx you two.

Zeugma

  • New Member
  • *
  • Posts: 10
0.9.1 installer/binary
« Reply #17 on: October 27, 2004, 12:00:17 am »
Hi everyone,

I now have the same problem as described above, even though you said it had been fixed.

Code: [Select]
Free Pascal Compiler version 1.0.10 [2003/06/27] for i386
Copyright (c) 1993-2003 by Florian Klaempfl
Target OS: Win32 for i386
Compiling interfaces.pp
Compiling win32int.pp
Compiling win32wsextctrls.pp
win32wsextctrls.pp(292,9) Hint: Parameter APARAMS not used
win32wsextctrls.pp(326,14) Error: Incompatible type for arg no. 1: Got RECT, expected LPRECT
win32wsextctrls.pp(531) Fatal: There were 1 errors compiling module, stopping
make[3]: *** [interfaces.ppw] Error 1
make[3]: Leaving directory `J:/lazarus/lcl/interfaces/win32'
make[2]: *** [win32_all] Error 2
make[2]: Leaving directory `J:/lazarus/lcl/interfaces'
make[1]: *** [interfaces] Error 2
make[1]: Leaving directory `J:/lazarus/lcl'
make: *** [lcl] Error 2


I'm using the Lazarus snapshot from 10/26/2004 and FPC 1.0.10.

It is also possible that I made a mistake while upgrading FPC, but I assume I have done all necessary :
- Downloading the last package (w321010full.zip)
- Installing to J:\lazarus\pp\
- Copying the new fcl, packages and rtl folders into J:\lazarus\fpcsrc
- Adding -FuJ:\lazarus\lcl\interfaces/$TARGET to fpc.cfg

Can anyone tell me what's wrong ? :(

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
Re: Error compiling with fpc 1.0.10
« Reply #18 on: October 27, 2004, 09:12:27 am »
Thanks for reporting. I think there is a bug in FPC 1.0.10. It doesn't see the right overloaded function. Although fpc 1.0.10 is still supported, none of the developers are using it on a daily basis. Using fpc 1.9.4 has also the advantage of better image support, so might think about installing fpc 1.9.4.

As a workaround for the fpc 1.0.10 bug, you can change line 326 of win32wsextctrls.pp to:
Code: [Select]
OffsetRect(@PageRect, -ParentRect.Left, -ParentRect.Top);

Zeugma

  • New Member
  • *
  • Posts: 10
0.9.1 installer/binary
« Reply #19 on: October 27, 2004, 02:19:16 pm »
Yay, it works ! Thanks Vincent !

I've tried using FPC 1.0.10 to get rid of a runtime error 216 that randomly prevented me from building my project :/ I'll see if that solves the problem...