Recent

Author Topic: Auto Format is off  (Read 4976 times)

jfreak53

  • New Member
  • *
  • Posts: 21
Auto Format is off
« on: May 29, 2011, 03:23:25 pm »
I just started using lazarus once more after a year or two and I noticed while typing it auto completed most of my code.  Which is awesome since I come from Delphi 7, and we all know it doesn't do that ha ha

Problem is it is incorrectly formatting the ":=" code.  It places that directly next to the previous text, like so:

Code: [Select]
edit1.text:='me';
While in reality it should be:

Code: [Select]
edit1.text := 'me';
Is there any place in the options to change the auto format and where I can separate that, it is driving my OCD crazy ha ha  %)

Thanks.

Leledumbo

  • Hero Member
  • *****
  • Posts: 8281
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Auto Format is off
« Reply #1 on: May 29, 2011, 03:42:16 pm »
Environment Options (or Tools->Options if you use snapshot / trunk)->Codetools->Space, check Symbol for both "insert in front of" and 'insert after".

fabienwang

  • Sr. Member
  • ****
  • Posts: 449
  • Lazarus is the best
    • My blog
Re: Auto Format is off
« Reply #2 on: May 29, 2011, 03:43:48 pm »
Go in the menu Environment->Options

Then in Codetools->Space:

insert space after
Check Identifier and Symbol.

You're done ;)
I'm using Arch Linux.
Known for: CPickSniff, OpenGrabby
Contributed to: LazPaint

jfreak53

  • New Member
  • *
  • Posts: 21
Re: Auto Format is off
« Reply #3 on: May 29, 2011, 04:08:33 pm »
Beautiful!!  :D  Thanks!  Your saving me from the looney bin here

 

TinyPortal © 2005-2018