Recent

Author Topic: MySQL package... Why?  (Read 6393 times)

joseywales72

  • Guest
MySQL package... Why?
« on: July 29, 2005, 10:45:44 am »
Hi,
I saw recent posts about MySql4 problems and decided to start a new thread, because it seems that nobody knows exactly what to do about the infamous "libmysql.dll" or "mysqlclient.dll" issue. I do not know either and I want to share my experiences. There are three different versions of Lazarus on my pc. (Windows XP-SP2) Compiler and environmental options for all three are the same. I can only manage to install MySQL4 package in 0.9.7 snapshot. Both 0.9.8 release and 0.9.9(26072005) snapshots return the said messages.
There is something wrong somewhere. But I do not know where. Whereabouts of "libmysql.dll" is irrelevant here because it is in system32.
As Lazarus getting near to a version 1.0 release, I think that, this issue/bug needs a urgent ironing out. All Lazarus installs are using default options except that in compiler options/other unit files= c:\lazarus\lcl\;C:\lazarus\components\units\i386\win32\
Thank you very much for such a great and free development tool.

Anonymous

  • Guest
RE: MySQL package... Why?
« Reply #1 on: September 23, 2005, 10:41:39 pm »
whats the intelligent message of this post?

Anonymous

  • Guest
RE: MySQL package... Why?
« Reply #2 on: October 03, 2005, 10:38:26 am »
the message is, that lazarus shouldn't become 1.0, since there is proper working support for mysql, which is really important to many, many people.
It should be the answer: download a maybe existing version of mysql, which is old - just to extract a dll, where you never know if it work properly, an then to try to compile lazarus to see, that it breakes.

lazarus neighter have odbc support.

except of these issues, lazarus is great for simple things, but if you want to make something with conventional and broad used db's, its a pain in the ass....

Anonymous

  • Guest
RE: MySQL package... Why?
« Reply #3 on: October 03, 2005, 10:39:08 am »
that is my interpretation of the post from the threadstarter.
sorry my english ^^

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2512
RE: MySQL package... Why?
« Reply #4 on: October 03, 2005, 02:29:30 pm »
The simple answer is: As long as the MySQL team thinks they can change interfaces between minor versions, there will only be some versions supported. Don't complain here, complain to those MySQL devels.
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

Anonymous

  • Guest
RE: MySQL package... Why?
« Reply #5 on: October 18, 2005, 05:53:17 pm »
and what about odbc support?
would it be possible to connect thru the odbc mysql adapter?
if odbc would work, we could use lazarus to work with mysql too. hopefully...

IgD

  • Jr. Member
  • **
  • Posts: 73
    • http://www.igdsoftware.com
RE: MySQL package... Why?
« Reply #6 on: October 20, 2005, 12:31:26 pm »
Use ZeosLib for MySQL support.  http://www.zeoslib.net.  It has a few bugs but works with MySQL 4 and 4.1.

 

TinyPortal © 2005-2018