Recent

Author Topic: "Smart Tabs" option and "ignore exception" don't seem to work in Lazarus 0.9.30  (Read 4484 times)

mgerwinski

  • New member
  • *
  • Posts: 6
Hello,

I recently upgraded to Lazarus 0.9.30.

Usually, I like to work without the "smart tabs" option, so first thing I do is, I switch it off. However, after un-setting the checkbox in the options dialog, there's no effect. E.g. when typing an "if ... then" clause, after hitting ENTER I am automatically indented 2 spaces to the right. But what I want is: staying right below the "if" and deciding about my indents myself.

In further news, whenever I'm running my application, and an exception pops up, and I set the "ignore exception type" checkbox, the exception still interrupts execution and drags me into the debug mode whenever it is raised, even though it is caught and handled.

Are these bugs in 0.9.30, or am I missing some other options that should take care of this?

Thank you very much in advance for any help,

  Markus

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5716
    • wiki
As for "smart tabs", check out the indent section, on the first option page for codetools. (there is a link, next to smart "auto indent"")

"smart tab" only acts if you press tab anyway. What you meant is "auto indent".

And there are 2 indenter now: The editor's, and codetool's

----
As for "ignore exception",  I had that a few times. i haven't worked out the exact pattern yet.
But I believe it has to do, with changing the debugger exe.

After you first time set up the debugger, or changed it, there seem to be problems. restarting lazarus helps.

I do not know if editing the list in the options dialog has the same issue. Adding them during debug, via the info dialog that pops up, when the exception occurred, seems to work (but only, if you did not just modify the debugger settings)

Note, this is only an approximate observation. I haven't tested all the cases and combinations yet...
« Last Edit: April 08, 2011, 03:36:54 pm by Martin_fr »

mgerwinski

  • New member
  • *
  • Posts: 6
And there are 2 indenter now: The editor's, and codetool's
That explains a lot... thank you very much. After I switched off the use of codetools, the IDE behaved as I wanted it.

After you first time set up the debugger, or changed it, there seem to be problems. restarting lazarus helps.
Restarting did the trick indeed. Strange. I would have sworn I already tried that.

Well, however. @Martin_fr, Thanks alot for your help! :-)