Recent

Author Topic: 20050718 snapshot of Lazarus is broken?  (Read 7190 times)

Phil H.

  • Guest
20050718 snapshot of Lazarus is broken?
« on: July 19, 2005, 12:43:52 am »
When I tried to build Lazarus after installing the 20050718 Win32 snapshot, I got this error after "Build JIT Form" completed:

make.exe[1]: ***[lazarus.res] Error1

No other information about the error was provided.

Thanks.

-Phil

Anonymous

  • Guest
20050718 snapshot of Lazarus is broken?
« Reply #1 on: July 19, 2005, 09:03:09 pm »
The makefile doesn't know how to create lazarus.res, if windres is not on the path.

The easiest solution, is to make sure you don't delete the file by doing a clean all, or clean+build IDE.

Alternatively add lazarus\pp\bin\i386-win32 to your path variable before starting lazarus.

I am thinking about how to fix the makefiles.

Vincent.

Phil H.

  • Guest
Same problem
« Reply #2 on: July 22, 2005, 08:45:20 pm »
Quote from: "Anonymous"
The makefile doesn't know how to create lazarus.res, if windres is not on the path.

The easiest solution, is to make sure you don't delete the file by doing a clean all, or clean+build IDE.

Alternatively add lazarus\pp\bin\i386-win32 to your path variable before starting lazarus.

I am thinking about how to fix the makefiles.

Vincent.



Vincent,

Adding that to my path doesn't help any. Same error as before when building the 20050722 Lazarus.

Thanks.

-Phil

Anonymous

  • Guest
20050718 snapshot of Lazarus is broken?
« Reply #3 on: July 28, 2005, 05:49:41 pm »
:cry: I am having the same problem.  I have set the path, and did a build without a clean.  I am using Windows XP.

Thanks,
Grimjaw

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
20050718 snapshot of Lazarus is broken?
« Reply #4 on: July 29, 2005, 10:18:56 pm »
If you don't do clean all, then it won't be removed and lazarus.res doesn't have to be made.

So install again, and go directly to the configure build lazarus dialog and uncheck the clean all checkbox.

I hope it will be fixed in the next release (0.9.10).

grimjaw

  • Guest
20050718 snapshot of Lazarus is broken?
« Reply #5 on: August 03, 2005, 03:43:22 pm »
Quote from: "Vincent"
If you don't do clean all, then it won't be removed and lazarus.res doesn't have to be made.

So install again, and go directly to the configure build lazarus dialog and uncheck the clean all checkbox.

I hope it will be fixed in the next release (0.9.10).
I uninstalled Lazarus, reinstalled and unchecked the clean all box before rebuilding.  This does allow the build to proceed to startlazarus, but prior to a startlazarus.exe linking error and a make error "make.exe[1]: ***[startlazarus.res] Error1" a lot of messages such as the following occur:

WinExt.pas:199: undefined reference to WINDOWS_SENDMESSAGE$LONGWORD$LONGWORD$LONGINT$LONGINT$$LONGINT'

I have tried this on 3 PCs with Windows XP all with the same results.  Hope this helps to track down the problem.

Thanks,
Grimjaw

Anonymous

  • Guest
20050718 snapshot of Lazarus is broken?
« Reply #6 on: August 04, 2005, 04:38:50 am »
FROM CERDEL
 I had a similar problem. Once lazarus was uninstalled,  I manually erase the folder I used (c:\lazarus). I install again and it works. Of course i have to add all the components I used. My computer is a Gateway SOLO 5150 with XP pro.

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
Re: 20050718 snapshot of Lazarus is broken?
« Reply #7 on: August 08, 2005, 04:18:46 pm »
Quote from: "Phil H."
When I tried to build Lazarus after installing the 20050718 Win32 snapshot, I got this error after "Build JIT Form" completed:

make.exe[1]: ***[lazarus.res] Error1



This error should be fixed in tomorrows snapshot (20050809)

Vincent.

Anonymous

  • Guest
RE: Re: 20050718 snapshot of Lazarus is broken?
« Reply #8 on: August 08, 2005, 10:30:00 pm »
Where ia found link to lazarus snapshots ? I lost it.  I'm waiting for 0.9.10, I hope a printing will be fixed...