Forum > LCL

LazOpenGLContext on Linux

(1/1)

Imants:
I am using Lazarus 0.9.31 FPC 2.5.1 and
I am trying to run LazOpenGLContext example on ubuntu 10.10. It compiles fine, but fails when linking with message:

/usr/bin/ld: cannot find -lGL
/usr/bin/ld: warning: link.res contains output sections; did you forget -T?
testopenglcontext1.lpr(14,1) Error: Error while linking
testopenglcontext1.lpr(14,1) Fatal: There were 1 errors compiling module, stopping

My be someone know why.

Leledumbo:
install the opengl libraries (I don't know from which package, search your package repositories).

Carver413:
I had to istall theses packages to get glscene working. some of it anyway. the demo is working for me so maybe thats all you need.
 dev-packages: libgl1-mesa-dev, libglu1-mesa-dev and libxxf86vm-dev

Imants:
thanks it really helped. Now I can run demo without problems :)

Navigation

[0] Message Index

Go to full version