Recent

Author Topic: How to install FPC 2.4.2 on Ubuntu ?  (Read 21431 times)

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
How to install FPC 2.4.2 on Ubuntu ?
« on: February 17, 2011, 05:24:39 pm »
Hi

I'd like to install the latest stable release of FPC and, following the wiki links, I download :

https://sourceforge.net/projects/freepascal/files/Linux/2.4.2/deb/fpc_2.4.2-0_all.deb/download

But fp-units-math dependance is not satisfied.

If I tried then to install the package fp-units-math.deb from the same directory, but another dependance is not satisfied...

In short, is there a meta package to install everything requested ? Or some information about the right order for installing different packages ?

Thanks for help !

Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

Blaazen

  • Hero Member
  • *****
  • Posts: 2994
  • POKE 54296,15
    • Eye-Candy Controls
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #1 on: February 17, 2011, 06:00:18 pm »
I don't know what exactly fpc_2.4.2-0_all.deb is, but it has only- 12.3 kB -> it is not what you need.  :)

You need:

fpc & fp-units-rtl & fp-source

All three are in Ubuntu repositories (version 2-4-2).

Lazarus 2.1.0 r64115 FPC 3.3.1 r40507 x86_64-linux-qt Chakra, Qt 4.8.7/5.13.2, Plasma 5.17.3
Lazarus 1.8.2 r57369 FPC 3.0.4 i386-win32-win32/win64 Wine 3.21

Try Eye-Candy Controls: https://sourceforge.net/projects/eccontrols/files/

cpalx

  • Hero Member
  • *****
  • Posts: 647
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #2 on: February 17, 2011, 07:08:52 pm »
did you try?:

dpkg -i *.deb

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #3 on: February 17, 2011, 07:14:59 pm »
Quote
You need:
fpc & fp-units-rtl & fp-source

Thanks for your reply.

I'm not alone to be stuck : fpc_2.4.2-0_all.deb is the most frequently downloaded from sourceforge, and is labelled as "the latest version"... (of what ?)

So, I can find fp-units-rtl & fp-source, but where do you find fpc ?

Regards,
Tintinux



Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #4 on: February 17, 2011, 07:18:20 pm »
Code: [Select]
did you try?:
dpkg -i *.deb

No, I never saw such an advice. But why not...

I suppose that before I must download some .deb, but which ones ?

Regards
Tintinux
Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

Blaazen

  • Hero Member
  • *****
  • Posts: 2994
  • POKE 54296,15
    • Eye-Candy Controls
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #5 on: February 17, 2011, 07:27:06 pm »
There is:

fp-compiler_2.4.2-0_i386.deb

 on link you mentioned (the very last).
Lazarus 2.1.0 r64115 FPC 3.3.1 r40507 x86_64-linux-qt Chakra, Qt 4.8.7/5.13.2, Plasma 5.17.3
Lazarus 1.8.2 r57369 FPC 3.0.4 i386-win32-win32/win64 Wine 3.21

Try Eye-Candy Controls: https://sourceforge.net/projects/eccontrols/files/

cpalx

  • Hero Member
  • *****
  • Posts: 647
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #6 on: February 18, 2011, 04:28:40 am »
in this pages

http://www.hu.freepascal.org/lazarus/

you have :

fpc debs

downloaded, UNTAR  and then

dpkg -i *deb


marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8892
  • FPC developer.
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #7 on: February 18, 2011, 09:33:18 am »
I always use the .tar installer on debian if I can't use the version in the normal deb repositories (which is usually very old)

One download, one extraction, one script to run.

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #8 on: February 19, 2011, 08:30:13 am »
Quote from: cpaix
in this pages
http://www.hu.freepascal.org/lazarus/
This is definitely not what I'm looking for.  I'm starting to use Lazarus for shared and professional development, and I can't play with untested snapshots.

Quote from: blaazen
There is:
fp-compiler_2.4.2-0_i386.deb
 on link you mentioned (the very last).
Quote from: marcov
I always use the .tar installer on debian
Ok, I'll try them as soon as possible. This will require time and a new computer because I can't risk to spend time without a working compiler.

If you want FPC and Lazarus used by more peole, it is very important to provide installation procedure, easy to find and to understand. A .deb is the best one for debian based systems. Isn't it possible to correct the "usually very old" package ?

Regards,
Tintinux
Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8892
  • FPC developer.
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #9 on: February 19, 2011, 11:26:16 am »
Quote from: marcov
I always use the .tar installer on debian
Ok, I'll try them as soon as possible. This will require time and a new computer because I can't risk to spend time without a working compiler.

If you want FPC and Lazarus used by more peole, it is very important to provide installation procedure, easy to find and to understand. A .deb is the best one for debian based systems. Isn't it possible to correct the "usually very old" package ?
[/quote]

Free Pascal provides own debs and all the metadata needed to build them. The delay is on the Ubuntu/Debian side, and their extremely long freezes.

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #10 on: March 02, 2011, 08:31:57 am »
Quote from: Marcov
Free Pascal provides own debs
Yes, but it is very difficult to understand which ones are requested (and working) for an OS.

Thus, it is obvious that Ubuntu packagers will need a long time to select and include the right packages in their repository. They are quicker when it's easier.

FPC and Lazarus would be much more popular if they were easier to install. IMHO this is the most important issue now.

Regards
Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #11 on: March 03, 2011, 06:32:57 pm »
Quote from: cpaix
in this pages
http://www.hu.freepascal.org/lazarus/
you have :
fpc debs
downloaded, UNTAR  and then
dpkg -i *deb

Hi !

I said at the beginning of my post : I'd like to install the latest stable release of FPC.

In the link, it is a snapshot untested release.

I must find the stable release but however, I tried on a new computer.

A lot of broken dependances are shown.
Sorry the computer is speaking french. I don't know if it is possible to get english messages. I can translate if needed.

Sélection du paquet fpc précédemment désélectionné.
(Lecture de la base de données... 225502 fichiers et répertoires déjà installés.)
Dépaquetage de fpc (à partir de fpc_2.4.2-0_all.deb) ...
Sélection du paquet fp-compiler précédemment désélectionné.
Dépaquetage de fp-compiler (à partir de fp-compiler_2.4.2-0_i386.deb) ...
Sélection du paquet fpc-source précédemment désélectionné.
Dépaquetage de fpc-source (à partir de fpc-source_2.4.2-0_all.deb) ...
Sélection du paquet fp-docs précédemment désélectionné.
Dépaquetage de fp-docs (à partir de fp-docs_2.4.2-0_all.deb) ...
Sélection du paquet fp-ide précédemment désélectionné.
Dépaquetage de fp-ide (à partir de fp-ide_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-base précédemment désélectionné.
Dépaquetage de fp-units-base (à partir de fp-units-base_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-db précédemment désélectionné.
Dépaquetage de fp-units-db (à partir de fp-units-db_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-fcl précédemment désélectionné.
Dépaquetage de fp-units-fcl (à partir de fp-units-fcl_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-fv précédemment désélectionné.
Dépaquetage de fp-units-fv (à partir de fp-units-fv_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-gfx précédemment désélectionné.
Dépaquetage de fp-units-gfx (à partir de fp-units-gfx_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-gnome1 précédemment désélectionné.
Dépaquetage de fp-units-gnome1 (à partir de fp-units-gnome1_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-gtk2 précédemment désélectionné.
Dépaquetage de fp-units-gtk2 (à partir de fp-units-gtk2_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-gtk précédemment désélectionné.
Dépaquetage de fp-units-gtk (à partir de fp-units-gtk_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-i386 précédemment désélectionné.
Dépaquetage de fp-units-i386 (à partir de fp-units-i386_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-math précédemment désélectionné.
Dépaquetage de fp-units-math (à partir de fp-units-math_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-misc précédemment désélectionné.
Dépaquetage de fp-units-misc (à partir de fp-units-misc_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-multimedia précédemment désélectionné.
Dépaquetage de fp-units-multimedia (à partir de fp-units-multimedia_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-net précédemment désélectionné.
Dépaquetage de fp-units-net (à partir de fp-units-net_2.4.2-0_i386.deb) ...
Sélection du paquet fp-units-rtl précédemment désélectionné.
Dépaquetage de fp-units-rtl (à partir de fp-units-rtl_2.4.2-0_i386.deb) ...
Sélection du paquet fp-utils précédemment désélectionné.
Dépaquetage de fp-utils (à partir de fp-utils_2.4.2-0_i386.deb) ...
Paramétrage de fpc-source (2.4.2-0) ...
Paramétrage de fp-docs (2.4.2-0) ...
dpkg : des problèmes de dépendances empêchent la configuration de fp-units-gtk :
 fp-units-gtk dépend de libgtk2.0-dev ; cependant :
  Le paquet libgtk2.0-dev n'est pas installé.
dpkg : erreur de traitement de fp-units-gtk (--install) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de fp-units-multimedia :
 fp-units-multimedia dépend de libogg-dev ; cependant :
  Le paquet libogg-dev n'est pas installé.
 fp-units-multimedia dépend de libvorbis-dev ; cependant :
  Le paquet libvorbis-dev n'est pas installé.
 fp-units-multimedia dépend de a52dec-dev ; cependant :
  Le paquet a52dec-dev n'est pas installé.
 fp-units-multimedia dépend de libdts-dev ; cependant :
  Le paquet libdts-dev n'est pas installé.
 fp-units-multimedia dépend de libmad0-dev ; cependant :
  Le paquet libmad0-dev n'est pas installé.
 fp-units-multimedia dépend de libmodplug-dev ; cependant :
  Le paquet libmodplug-dev n'est pas installé.
dpkg : erreur de traitement de fp-units-multimedia (--install) :
 problèmes de dépendances - laissé non configuré
Paramétrage de fp-units-rtl (2.4.2-0) ...
Paramétrage de fp-utils (2.4.2-0) ...
dpkg : des problèmes de dépendances empêchent la configuration de fpc :
 fpc dépend de fp-units-gtk ; cependant :
 Le paquet fp-units-gtk n'est pas encore configuré.
 fpc dépend de fp-units-multimedia ; cependant :
 Le paquet fp-units-multimedia n'est pas encore configuré.
dpkg : erreur de traitement de fpc (--install) :
 problèmes de dépendances - laissé non configuré
Paramétrage de fp-compiler (2.4.2-0) ...
update-alternatives: utilisation de « /usr/bin/fpc » pour fournir « /usr/bin/pc » (pc) dans mode automatique.

Paramétrage de fp-ide (2.4.2-0) ...
Paramétrage de fp-units-base (2.4.2-0) ...
Paramétrage de fp-units-db (2.4.2-0) ...
Paramétrage de fp-units-fcl (2.4.2-0) ...
Paramétrage de fp-units-fv (2.4.2-0) ...
Paramétrage de fp-units-gfx (2.4.2-0) ...
dpkg : des problèmes de dépendances empêchent la configuration de fp-units-gnome1 :
 fp-units-gnome1 dépend de fp-units-gtk (= 2.4.2-0) ; cependant :
 Le paquet fp-units-gtk n'est pas encore configuré.
dpkg : erreur de traitement de fp-units-gnome1 (--install) :
 problèmes de dépendances - laissé non configuré
Paramétrage de fp-units-gtk2 (2.4.2-0) ...
Paramétrage de fp-units-i386 (2.4.2-0) ...
Paramétrage de fp-units-math (2.4.2-0) ...
Paramétrage de fp-units-misc (2.4.2-0) ...
Paramétrage de fp-units-net (2.4.2-0) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « doc-base »...
Processing 2 added doc-base file(s)...
Registering documents with scrollkeeper...
Des erreurs ont été rencontrées pendant l'exécution :
 fp-units-gtk
 fp-units-multimedia
 fpc
 fp-units-gnome1


Best regards,
Tintinux





Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

fabienwang

  • Sr. Member
  • ****
  • Posts: 449
  • Lazarus is the best
    • My blog
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #12 on: March 03, 2011, 06:45:15 pm »
Tintinux, try installing the following package:
libgtk2.0-dev

sudo apt-get install libgtk2.0-dev
I'm using Arch Linux.
Known for: CPickSniff, OpenGrabby
Contributed to: LazPaint

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #13 on: March 03, 2011, 07:44:50 pm »
Thanks Fabien, it was installed without error like this.

Doesn't this simply mean that a dependance to libgtk2.0-dev is missing in fp-units-gtk2_2.4.2-0_i386.deb or another package ?

Best regards,
Martin 

Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

fabienwang

  • Sr. Member
  • ****
  • Posts: 449
  • Lazarus is the best
    • My blog
Re: How to install FPC 2.4.2 on Ubuntu ?
« Reply #14 on: March 03, 2011, 08:32:03 pm »
i'm not sure about the packages, but as long as it tells you what dependency is not satisfied, you are able to install it :)

Regards,
Fabien
I'm using Arch Linux.
Known for: CPickSniff, OpenGrabby
Contributed to: LazPaint

 

TinyPortal © 2005-2018