Recent

Author Topic: zeosdbo,oracle10g  (Read 4402 times)

anlan

  • Newbie
  • Posts: 1
zeosdbo,oracle10g
« on: February 16, 2011, 06:02:41 am »
I will connect to Oracle10g via zeosdbo component.
I had set all parameters in ZConnections.
When I set the property of 'connected' to true,it appears the error,such as the follow:
[0E76AF90]{ZPlain140.bpl} Zplainoracledriver.TZOracle9iPlainDriver.EnvNlsCreate + $40
[02A0FD99]{ZDbc140.bpl } Zdbcoracle.TZOracleConnection.Open + $C5
[02A0FBB1]{ZDbc140.bpl } Zdbcoracle.TZOracleConnection + $D5
[02A0F8B2]{ZDbc140.bpl } Zdbcoracle.TZOracleDriver.Connect + $9E
[02973A49]{ZDbc140.bpl } Zdbcintfs. + $0
[02B10ADB]{ZComponent140.bpl} Zconnection.TZConnection.Connect + $173
[02B10405]{ZComponent140.bpl} Zconnection.TZConnection.SetConnected + $2D
[500516F2]{rtl140.bpl  } TypInfo.SetOrdProp (Line 1727, "TypInfo.pas" + 31) + $0
[20DA5FF2]{designide140.bpl} DesignEditors.TPropertyEditor.SetOrdValue (Line 841, "DesignEditors.pas" + 2) + $E
[20DA713F]{designide140.bpl} DesignEditors.TEnumProperty.SetValue (Line 1410, "DesignEditors.pas" + 5) + $4
[20DA5C61]{designide140.bpl} DesignEditors.TPropertyEditor.Edit (Line 671, "DesignEditors.pas" + 11) + $14
[20976C8E]{coreide140.bpl} PropInsp.TPropertyInspector.PropListEditDblClick (Line 870, "PropInsp.pas" + 21) + $1
[20EC2F75]{vclide140.bpl} IDEInspListBox.TInspListBox.DoEditDblClick (Line 617, "IDEInspListBox.pas" + 2) + $A
[20EC47EA]{vclide140.bpl} IDEInspListBox.TInspListBox.EditDblClick (Line 1188, "IDEInspListBox.pas" + 0) + $2
[502963F9]{vcl140.bpl  } Controls.TControl.DblClick (Line 7183, "Controls.pas" + 1) + $14
[50296574]{vcl140.bpl  } Controls.TControl.WMLButtonDblClk (Line 7226, "Controls.pas" + 4) + $C
[50295E70]{vcl140.bpl  } Controls.TControl.WndProc (Line 7062, "Controls.pas" + 91) + $6
[502A2FC8]{vcl140.bpl  } Controls.TDockTree.WndProc (Line 15250, "Controls.pas" + 74) + $5
[5029A018]{vcl140.bpl  } Controls.TWinControl.IsControlMouseMsg (Line 9604, "Controls.pas" + 9) + $25
[5029A738]{vcl140.bpl  } Controls.TWinControl.WndProc (Line 9819, "Controls.pas" + 144) + $6
[20EC26E7]{vclide140.bpl} IDEInspListBox.TPropInspEdit.WndProc (Line 359, "IDEInspListBox.pas" + 7) + $4
[50299DD8]{vcl140.bpl  } Controls.TWinControl.MainWndProc (Line 9540, "Controls.pas" + 3) + $6
[50076408]{rtl140.bpl  } Classes.StdWndProc (Line 13015, "Classes.pas" + 8) + $0
[5029098A]{vcl140.bpl  } Controls.FindControl (Line 3377, "Controls.pas" + 6) + $9
[502C8775]{vcl140.bpl  } Forms.TApplication.ProcessMessage (Line 9760, "Forms.pas" + 30) + $1
[502C87BA]{vcl140.bpl  } Forms.TApplication.HandleMessage (Line 9790, "Forms.pas" + 1) + $4
[502C8AE5]{vcl140.bpl  } Forms.TApplication.Run (Line 9927, "Forms.pas" + 26) + $3
[004369AE]{bds.exe     } bds.bds (Line 200, "" + 8) + $FFFB

Who can tell me how I will solve the problem? Thanks.
« Last Edit: February 16, 2011, 06:20:44 am by anlan »

DirkS

  • Sr. Member
  • ****
  • Posts: 251
Re: zeosdbo,oracle10g
« Reply #1 on: February 16, 2011, 10:45:04 am »
What's the error? All I see is some sort of stacktrace.
Is this actually in Lazarus / FreePascal?

Gr.
Dirk.

 

TinyPortal © 2005-2018