Recent

Author Topic: Ubuntu 10.10 and Daily Builds issues (Unit not found: RegisterLCL)  (Read 3773 times)

Hansaplast

  • Hero Member
  • *****
  • Posts: 596
  • Tweaking4All.com
    • Tweaking4All
I'm not a Linux expert by far, and I've been trying to get a daily build to run on Ubuntu 10.10.
I've spend numerous nights trying to get it to go, but no success so far ...

I've tried the debs, but it gives me a "LCLBase 1.0" - "Unit not found: RegisterLCL" error.
Can't rebuild, it either will not let me, or (using sudo) will not complete.
Ignoring this message does allow me to compile an application, but my app uses lazreports which I need to add ... :(

I've tried the svn, which produces the same message (followed these steps - great post by the way!).

I've found this error elsewhere in this forum, but no solution is presented.
I've also found it in the bug tracker, and provided additional info, but no solution/work around available yet.
(note: not intended as a complaint! I can only image the amount of work the devs have and greatly respect them for it)

The stable version works, but I can't compile my application (I've developed the app with a Daily Build on the Mac - the lazreports version doesn't match up).
Note: I can compile the application under Windows 7 (32 bit) with the Daily Build just fine.

I was just wondering if anyone out here with a little more Lazarus/Linux experience can help me out  :-[
I don't mind an error message or two, just would like to be able to add lazreports and compile my app :)

Hansaplast

  • Hero Member
  • *****
  • Posts: 596
  • Tweaking4All.com
    • Tweaking4All
Re: Ubuntu 10.10 and Daily Builds issues (Unit not found: RegisterLCL)
« Reply #1 on: February 06, 2011, 07:47:24 am »
seems there might be a workaround after all: link

 

TinyPortal © 2005-2018