Forum > Windows (32/64)

Can't compile unit INTERFACEBASE

(1/1)

Didier69:
Hello,

I try to install lazarus on win2k, and when I try to compile a little example, I got this error :

Can't compile unit INTERFACEBASE,  no sources available.

I think I don't need to recompile this unit no ? Where do I disable this option of recompilation ?

Thanks.

Vincent Snijders:
Go to Run, Compiler Options,  Paths, LCL Widget Type.
Is widget set default or win32?

Didier69:
Hi Vincent,

default (win32) or win32 gives me the same error

(sorry for PM :))

Vincent Snijders:
Just guessing....

Another possibilty could be, that the compiler you compiled lazarus (and the lcl) with, is not the same as the compiler you used to compile your sample program.

What compiler did you use to compile the LCL (or did you get a precompiled version)?

The compiler used to compile your example, can be set in the environment options.

HTH,
Vincent.

Didier69:
I resolved the problem : I didn't installed the FPC from lazarus. So I restarted from the beggining, and I installed FPC from lazarus installation and now it works !

Navigation

[0] Message Index

Go to full version