Forum > macOS / Mac OS X

No fpc.cfg

(1/4) > >>

certsoft:
I installed fpc, fpcsrcs, and lazarus from the snapshots at "http://www.ca.freepascal.org/Lazarus/". Following the directions in "http://lazarus-ccr.sourceforge.net/kb/index.php/Installing_Lazarus" I did get the IDE to start up. By the way there is a typo in the installation instructions, it should be "sudo fink install gdk-pixbuf ...." instead of "gtk-pixbuf".

Whe I try to test the "compiler options" ppcppc can't find fpc.cfg, in fact, I can't find a fpc.cfg file anywhere on the computer. The installation instructions indicate it should be "/etc" but it isn't there, nor is any of the "/usr/..." directories that I can determine. I haven't been able to find what is supposed to be in that file to re-create it. Who was supposed to create it? What is supposed to be in fpc.cfg?

Vincent Snijders:
The fpc package was supposed to create it. I will check it later this week.

Thanks for testing these packages.

certsoft:
In the installation log it says it tried to write it to "//etc/fpc.cfg" instead of "/etc/fpc.cfg". Hope that helps.

Vincent Snijders:
I just uploaded a new snapshots at http://www.ca.freepascal.org/Lazarus/. Can you test, if this fpc installer creates a correct etc.fpc ?

Anonymous:
The new version installed fpc.cfg correctly. Tried to get it to compile a simple test program consisting of a label and button, but it says "unit interfaces not found" even though it comes up with the interfaces.pp file in the editor. When running the compiler test it can't find, among other things, strings.pp even though I put the path to it in the source path list.

I've put some of the files where you can get to them:
http://www.certsoft.com/lazarus/fpc.cfg     - from /etc/
http://www.certsoft.com/lazarus/fpc_install.log   - from the system info installation log after installing fpc
http://www.certsoft.com/lazarus/laz_install.log   - after installing lazarus, I didn't notice the fpcsrc installation writing anything to the log.
http://www.certsoft.com/lazarus/compoptions1.xml  - compiler options

Other files that I didn't write but found had been created:
http://www.certsoft.com/lazarus/environmentoptions.xml
http://www.certsoft.com/lazarus/includelinks.xml
http://www.certsoft.com/lazarus/lazarus.dci
http://www.certsoft.com/lazarus/packageeditorlayouts.xml
http://www.certsoft.com/lazarus/protocol.xml
http://www.certsoft.com/lazarus/inputhistory.xml

I'm not sure how to get the results of the compiler test, is there a file that it writes someplace?

Bob

Navigation

[0] Message Index

[#] Next page

Go to full version