Recent

Author Topic: Glscene with lazarus svn  (Read 11874 times)

scrat

  • New member
  • *
  • Posts: 8
Glscene with lazarus svn
« on: September 12, 2010, 04:33:18 pm »
Hello

GLScene seems no longer work with the  lazarus svn and freepscal 2.5.1. (linux ubuntu 10.04)

Installation is ok after modified GTKproc / GtkDef in GTK2proc /GTK2Def.
Examples (megacube) compiles well but there is no rendering in the glviewer, only the fps is displayed.

is there a patch or a solution

Thanks





« Last Edit: September 12, 2010, 04:35:50 pm by scrat »

YarUnderoaker

  • New Member
  • *
  • Posts: 32
Re: Glscene with lazarus svn
« Reply #1 on: September 13, 2010, 07:46:01 pm »
Try last revision of our GLScene https://sourceforge.net/projects/glscene/
but not release 1.1, it's can't compile in Lazarus.
At least I can now provide support, if there would be problems.

jeehell

  • Newbie
  • Posts: 1
Re: Glscene with lazarus svn
« Reply #2 on: September 20, 2010, 09:20:32 pm »
Hi,

I cannot install the latest rev 5044 with Lazarus 0.9.29/FPC 2.4.3 under win 7 XP.
I get the following errors:

Quote
D:\Programmes\Lazarus\components\Glscene\Source\Base\VectorGeometry.pas(1021,11) Error: Function is already declared Public/Forward "SinCos(const Double,var Double,var Double);"
D:\Programmes\Lazarus\components\Glscene\Source\Base\VectorGeometry.pas(1029,11) Error: Function is already declared Public/Forward "SinCos(const Double,const Double,var Double,var Double);"
D:\Programmes\Lazarus\components\Glscene\Source\Base\VectorGeometry.pas(1133,10) Error: Function is already declared Public/Forward "MinFloat(const Double,const Double):Double;"
D:\Programmes\Lazarus\components\Glscene\Source\Base\VectorGeometry.pas(1136,10) Error: Function is already declared Public/Forward "MinFloat(const Double,const Double,const Double):Double;"
D:\Programmes\Lazarus\components\Glscene\Source\Base\VectorGeometry.pas(1145,10) Error: Function is already declared Public/Forward "MaxFloat(const Double,const Double):Double;"
D:\Programmes\Lazarus\components\Glscene\Source\Base\VectorGeometry.pas(1148,10) Error: Function is already declared Public/Forward "MaxFloat(const Double,const Double,const Double):Double;"
D:\Programmes\Lazarus\components\Glscene\Source\Base\VectorGeometry.pas(1388,19) Fatal: There were 6 errors compiling module, stopping

I read somewhere to use compiler directives but no luck with that.

Any idea?
Thanks in advance...
JeeHell

scrat

  • New member
  • *
  • Posts: 8
Re: Glscene with lazarus svn
« Reply #3 on: September 27, 2010, 06:34:17 pm »
Hello YarUnderoaker

I  tested your glscene SVN revision 5190 on Ubuntu 10.04 Fpc 2.5.1 and Lazarus SVN

In GLScreen.pas i have modified

Code: [Select]
if XF86VidModeQueryExtension( vDisplay, @i, @j )=0
by
if not XF86VidModeQueryExtension( vDisplay, @i, @j )

because I had this error message
Quote
/lazarus/components/glscene/Source/Platform/GLScreen.pas(325,6) Error: Incompatible types: got "LongBool" expected "LongInt"

In glviewer.ps i add this uses ==> Gl
because Gl_True et Gl_False  are unknown in
Code: [Select]
vsmSync  : glXSwapIntervalSGI(GL_True);
vsmNoSync: glXSwapIntervalSGI(GL_False);

Now Glscene compile.

I have tested a few examples that works after smales changes

In all examples replace
Code: [Select]
uses windows, .........................

by

uses
{$ifdef MSWINDOWS}
windows,
{$endif}     

The path for media directory is not at the right place for DemosLCL and the case is not good for linux.

Example tested and working :

megaglasscube
smoking
volcano
fog
nutsnbolts
manual
camera
demogizmoex
spline
projection after add  gl in uses
heightfield
fxy

Not working
multisampletexture don't work in linux ->api windows
megacube (just a very very little red cube)


Thank's


hgabor47

  • New member
  • *
  • Posts: 6
Re: Glscene with lazarus svn
« Reply #4 on: October 03, 2010, 09:31:43 pm »
Hi, please let me known, how the solution work. Or perhaps an ubuntu virtual ISO :) I have same problem... and now I have the last messages:


/usr/bin/ld: warning: /home/hgabor47/.lazarus/bin/link.res contains output sections; did you forget -T?
/usr/lib/fpc/2.4.0/units/i386-linux/gtk1/gtk.o: In function `GTK_GTK_CHECK_CLASS_TYPE$PGTKTYPECLASS$LONGWORD$$BOOLEAN':
gtk.pp:(.text+0x111): undefined reference to `gtk_type_is_a'
/usr/lib/fpc/2.4.0/units/i386-linux/gtk1/gtk.o: In function `GTK_GTK_IS_DATA_CLASS$POINTER$$BOOLEAN':
gtk.pp:(.text+0x3bd): undefined reference to `gtk_data_get_type'
/usr/lib/fpc/2.4.0/units/i386-linux/gtk1/gtk.o: In function `GTK_GTK_IS_PACKER_CLASS$POINTER$$BOOLEAN':
gtk.pp:(.text+0xead): undefined reference to `gtk_packer_get_type'
/usr/lib/fpc/2.4.0/units/i386-linux/gtk1/gdk.o: In function `GDK_GDK_GET_ROOT_WINDOW$$PGDKWINDOW':
gdk.pp:(.text+0x111): undefined reference to `gdk_root_window'
/usr/lib/fpc/2.4.0/units/i386-linux/gtk1/gdk.o: In function `GDK_GDK_GET_ROOT_PARENT$$PGDKWINDOW':
gdk.pp:(.text+0x121): undefined reference to `gdk_root_parent'
/usr/lib/lazarus/0.9.28.2/ide/lazarus.pp(129,1) Error: Error while linking
/usr/lib/lazarus/0.9.28.2/ide/lazarus.pp(129,1) Fatal: There were 1 errors compiling module, stopping


so... i'm tired. :(

 

scrat

  • New member
  • *
  • Posts: 8
Re: Glscene with lazarus svn
« Reply #5 on: October 04, 2010, 07:45:13 am »
Hi

With glscene from this SVN :
http://sourceforge.net/projects/glscene/files/

I have tested with FPC SVN 2.5.1 and Lazarus SVN.
GLscene seems to works after smalls modifications.

Your FPC version is 2.4.1, you can try SVN from freepascal repository

Now I use openglcontext .........

YarUnderoaker

  • New Member
  • *
  • Posts: 32
Re: Glscene with lazarus svn
« Reply #6 on: October 07, 2010, 04:11:18 pm »
Hi all.
I suggest you go to our official forum https://sourceforge.net/apps/phpbb/glscene/index.php
I often visit there.

I have Ubuntu 10.04 AMD64 and FPC 2.4.0. (there GLScene work), but I can't test FPC 2.5.1. because have small Linux skill and don't not where it got.
« Last Edit: October 07, 2010, 04:20:16 pm by YarUnderoaker »

 

TinyPortal © 2005-2018