* * *

Author Topic: Lazarus dont like Ubuntu 10.4 ...?  (Read 14281 times)

Fred vS

  • Hero Member
  • *****
  • Posts: 1181
    • miXimum is the DJ's best friend
Lazarus dont like Ubuntu 10.4 ...?
« on: April 20, 2010, 10:04:25 pm »
Hello.
I work with Lazarus for a long time now.
I create sharewares, i use Ubuntu  8 and 9, no problems with Lazarus.
I just have installed Ubuntu 10.4 and now, all the sharewares i have developed give a Acces Violation message...
I have also installed Lazarus  9.29 on Ubuntu 10.4 and if i click on Files for example in project options i get a Access violation message too, also with a simple Hello world prog... %)

If somebody have installed Ubuntu 10.4, could he try to install MiXimum for linux from my site (a DJ prog like Virtual DJ) :
http://sites.google.com/site/fiensprototyping/

The problem appears when trying to create a new song list ( maybe it appends only on my computer )

Thanks to say if its appends for you too.
« Last Edit: April 20, 2010, 10:21:55 pm by fredvs »
Many thanks.

I use Lazarus 1.1.2 32/64 and FPC 2.6.2 32/64  on Mint Mate 1.6.1 32/64, Windows 7 32/64, Windows XP 32 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, Win32, GTK2, Qt, Carbon.

silvioprog

  • Sr. Member
  • ****
  • Posts: 363
    • My public projects
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #1 on: April 21, 2010, 02:59:29 am »
First congratulations on your project, it's excellent!

This same problem happens to me, but not always. It happens especially when I open a TOpenDialog, or when I list items on it.
Silvio Clécio
My public projects - github.com/silvioprog

zeljko

  • Sr. Member
  • ****
  • Posts: 483
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #2 on: April 21, 2010, 08:28:04 am »
it's known gtk2 theme problem.

Ñuño_Martínez

  • Sr. Member
  • ****
  • Posts: 297
    • Burdjia
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #3 on: April 21, 2010, 08:59:03 am »
Curious: I have Lazarus 0.9.28.2-0beta and Kubuntu 9.10 and I can't use any open or save dialog.

I open the  IDE. Then select the Open... menu option to open a new project. The dialog appears. Then I select a directory and the IDE dead with an unhandled exception only visible if I run the IDE from a console terminal.

I've recompiled the IDE with GTK2 and GTK and fails in both cases.
« Last Edit: April 21, 2010, 09:03:02 am by Ñuño_Martínez »

Ocye

  • Sr. Member
  • ****
  • Posts: 399
    • Scrabble3D
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #4 on: April 21, 2010, 09:39:00 am »
Ubuntu 10.04 runs almost perfectly. I have neither problems compiling code nor running apps. You program starts well and a playlist folder is created if the parent folder has no write protection and the filename isn't empty. AV comes when I "close" the dialogue with "open" but no filename has been specified.
Lazarus 1.3 r44426M FPC 2.6.4 x86_64-linux-qt

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1384
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #5 on: April 21, 2010, 12:03:11 pm »
As zeljko mentioned it is a known gtk2 theme problem.
For me it happened under KDE in OpenSuse.
The solution is to switch to another gtk2 theme or use the SVN trunk version of Lazarus, and/or compile Lazarus for QT bindings (which I recommend anyway).

Juha

Fred vS

  • Hero Member
  • *****
  • Posts: 1181
    • miXimum is the DJ's best friend
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #6 on: April 24, 2010, 01:17:29 pm »
Hello folks.
Many thanks for your suggestions but... it didnt work.
I have installed back Ubuntu 9.04 and everything works perfect now.

I have a Acer Asprire 3810T (brand new with Windows 7) and gonna wait for the official release of Ubuntu 10.4.

PS No problems with Windows 7 and MiXimum on my PC, I hope for you too...
PS2 Also no problems with Windows 7 and Lazarus 9.29, compile MiXimum like charms...

Thanks
Many thanks.

I use Lazarus 1.1.2 32/64 and FPC 2.6.2 32/64  on Mint Mate 1.6.1 32/64, Windows 7 32/64, Windows XP 32 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, Win32, GTK2, Qt, Carbon.

Fred vS

  • Hero Member
  • *****
  • Posts: 1181
    • miXimum is the DJ's best friend
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #7 on: April 26, 2010, 11:19:19 pm »
Help ...., Super Marc, i beg you help please..
I have reinstalled Ubuntu 10.4, with new updates but, when i try to add some files in my prog MiXimum, i get a Violation acces messages (like i explain before).

I get this message if i load miximum from console :

TApplication.HandleException Access violation
  Stack trace:
  $00607E1E
  $081C3ECC
  $081074EB
  $0810674A
  $080DF48F
  $080DF085
  $080DFFFA
  $080DF585
  $080DF085
  $080DA51A
  $080DDB2D
  $080E0E9B
  $081D824A
  $080DC3A2
  $080E3978
  $080E89AD
  $080E6672


Also acces violation if i want to load the codes of MiXimum in Lazarus.
A message with, Acces violation Would you load the prg OK and Cancel.
If i click OK, it load and it is possible to compile.

If i run it from lazarus and try to add some files, i get the same Access violation, the debugger give me lots of error assembler.

The question is :

Must i say in my web page that MiXimum is not working with Ubuntu 10.4 ?
Why is it not possible to rebuild lazarus in Ubuntu 10.4, i get the message :
fatal error
Cant create object file :/units/i386-linux/lazaruspackageintf.o


Thanks for your help

PS No problems with Windows 7



« Last Edit: April 26, 2010, 11:25:58 pm by fredvs »
Many thanks.

I use Lazarus 1.1.2 32/64 and FPC 2.6.2 32/64  on Mint Mate 1.6.1 32/64, Windows 7 32/64, Windows XP 32 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, Win32, GTK2, Qt, Carbon.

Leledumbo

  • Hero Member
  • *****
  • Posts: 5225
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #8 on: April 27, 2010, 03:33:18 am »
Quote
Why is it not possible to rebuild lazarus in Ubuntu 10.4, i get the message
This is asked very often. Do we have this entry in FAQ (developers, wiki writers)?

The problem is that .debs are installer under /usr/lib, where you usually don't have write access. Rebuilding Lazarus involves writing there, so you normally can't do it. Either log in as root when you want to install some components, or run startlazarus with sudo, or give write access to Lazarus folder.

Fred vS

  • Hero Member
  • *****
  • Posts: 1181
    • miXimum is the DJ's best friend
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #9 on: April 27, 2010, 11:38:22 am »
Hello
Thanks Leledumbo, of course if i load sudo startlazarus, i can rebuild lazarus (changing permission of folder lazarus dont work).
But i have still that message if i want to load my project, it seems that lazarus cant load all the forms :

fred@fred-laptop:~$ sudo startlazarus
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF
TLazarusManager.Run starting /usr/share/lazarus/lazarus ...
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/home/fred/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
TApplication.HandleException Access violation
  Stack trace:
  $00790E1E
  $082CA3FC
  $081F4ADB
  $081F3D3A
  $081B297F
  $081B2575
  $081B34EA
  $081B2A75
  $081B2575
  $081B34EA
  $081B2A75
  $0807B881
  $08080C65
  $08081D09
  $081B2575
  $081B34EA
  $081B1611


And, for my prog MiXimum, i still dont have any solution for creating a new song list (or adding some tunes to a existing list), everything was working so fine till Ubuntu 9.10...
 :'(
« Last Edit: April 27, 2010, 11:41:15 am by fredvs »
Many thanks.

I use Lazarus 1.1.2 32/64 and FPC 2.6.2 32/64  on Mint Mate 1.6.1 32/64, Windows 7 32/64, Windows XP 32 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, Win32, GTK2, Qt, Carbon.

jhmos

  • New member
  • *
  • Posts: 24
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #10 on: April 27, 2010, 01:20:04 pm »
To be able to install components/recompile Lazarus I do from a console:
sudo chown -R myusername /usr/lib/lazarus

That has always worked fine for me and I just verified it on Ubuntu 10.04 64bit.

I also tried installing MIXimum, but at startup it complains that "Audio driver is not or already loaded ..."

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2460
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #11 on: April 28, 2010, 09:01:14 am »
Just curious, this has nothing to do with your crash, but what keyboard and language are you using ? Normally lazarus should not get out of VK codes.

fred@fred-laptop:~$ sudo startlazarus
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF

//--
{$I stdsig.inc}
//-Patches are always welcome at patch (at) dommelstein.net (please put the word "patch" in the subject)
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

bflm

  • Jr. Member
  • **
  • Posts: 54
    • Free Pascal Random Bits
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #12 on: April 28, 2010, 01:37:07 pm »
Just curious, this has nothing to do with your crash, but what keyboard and language are you using ? Normally lazarus should not get out of VK codes.

Sorry to jump in while not beeing asked: FYI, I have the same 'out of VK codes' with LANG=cs_CZ.UTF-8 for as long I could remeber. I get used to it in such a way, that I convinced myself it's a known but not yet resolved bug and so I never reported it. Shame on me.

Ñuño_Martínez

  • Sr. Member
  • ****
  • Posts: 297
    • Burdjia
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #13 on: April 28, 2010, 01:59:34 pm »
Just curious, this has nothing to do with your crash, but what keyboard and language are you using ? Normally lazarus should not get out of VK codes.

fred@fred-laptop:~$ sudo startlazarus
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF
[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of unassigned VK codes, assigning $FF

 :( I have also those "VK codes" warnings. I have Spanish keyboard on Kubuntu 9.10.

Fred vS

  • Hero Member
  • *****
  • Posts: 1181
    • miXimum is the DJ's best friend
Re: Lazarus dont like Ubuntu 10.4 ...?
« Reply #14 on: April 28, 2010, 08:46:57 pm »
Hello Marc.
I use a French keyboard (fr azerty) and lazarus is in French language...
Lazarus version 0.9.29
FPC 2.5.1
i386-linux-gtk 2 (beta)
« Last Edit: April 28, 2010, 08:58:08 pm by fredvs »
Many thanks.

I use Lazarus 1.1.2 32/64 and FPC 2.6.2 32/64  on Mint Mate 1.6.1 32/64, Windows 7 32/64, Windows XP 32 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, Win32, GTK2, Qt, Carbon.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads