* * *

Author Topic: [SOLVED] Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O  (Read 11734 times)

ϻαϻɾΣɀО

  • New member
  • *
  • Posts: 26
  • error = (more code)² «» e=mc²
[SOLVED] Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« on: April 24, 2016, 11:58:37 pm »
This problem has solved!

All of these happens when you upgrade to Ubuntu 16.04,
However if you install new fresh and clear Ubuntu you face to disappearance of these packages:
  Anchordockingdsgn
  Lazprojectgroups
  And some other than I have never tried before....

So if you need packages mentioned above
  For Ubuntu upgraded to 16.04
      Uninstall fpc and lazarus Old and new of ones
      Install fpc from repo
      Get Lazarus from trun and make it!
 
   For new Ubuntu installation:
     Install fpc from repo
     Install dependencies:
         sudo apt-get install build-essential
         sudo apt-get install libgtk2.0-dev
         sudo apt-get install libgdk-pixbuf-dev
     Get Lazarus from trun and make it!
   
For more information http://wiki.freepascal.org/Installing_Lazarus#Installing_from_source

For who one no need these packages just install the Fpc and the Lazarus from repo.
------------------------------------------------------------------------------------------------------------------------------------------------



Hi every body
Did any one installed Lazarus on Ubuntu 16.06?
Tonight I did it and sadly something went wrong... %)

I'd just upgrade to Ubuntu 16.04 and not a clean installation of it
So my nightmare starts with conflicts between my installed packages of fpc-src and fpc with new ones on the Ubuntu repositories :
  fp-compiler fp-compiler-3.0.0 fp-ide-3.0.0 fp-units-base-3.0.0 fp-units-db-3.0.0 fp-units-fcl-3.0.0 fp-units-fv-3.0.0 fp-units-gfx-3.0.0 fp-units-gtk2-3.0.0 fp-units-math-3.0.0
  fp-units-misc-3.0.0 fp-units-multimedia-3.0.0 fp-units-net-3.0.0 fp-units-rtl-3.0.0 fp-utils-3.0.0 fpc fpc-3.0.0 fpc-source-3.0.0 gir1.2-gtk-2.0

After reboot first launch of Lazarus Ide notice me fpc configuration lost?!  :-\ the conflict I said!

Let me short the story....

What I'd completely removed the any version of both fpc and Lazarus!
Then reinstalled from Ubuntu repositories

Some packages that normally provided by lazarus! Packages such (AnchorDockingDsgn, favorites, LazControlDsgn, lazprojectgroups) or editortoolbar not installed by default and installing it causes:
lazarus.pp(1,1) Fatal: Cannot find editortoolbar used by Lazarus. Check if package editortoolbar creates editortoolbar.ppu, check nothing deletes this file and check that no two packages have access to the unit source..

I'd tried to remove anything and install from packages provided by Lazarus team but lazarus_1.6-0_amd64.deb failed to install!
Errors were encountered while processing:
 Lazarus
And the installation stops here.

Question:
  Is there anyone installed and launches successfully Lazarus on Ubuntu 16.04,

Also I've seen somthing about Lazarus 1.6.2 on page: "Lazarus 1.6 fixes branch"

What I CAN DO NOW?
Is there any known and easy way instead of compile Lazarus from source? :-[
My life depends on Lazarus and it's latest version  8) But NOW  >:( :'(
May I return to Ubuntu 15.04  :(

Thanks for your responses... 
 
« Last Edit: May 16, 2016, 11:11:59 pm by ϻαϻɾΣɀО »
error = (more code)² «» e=mc²

Jurassic Pork

  • Hero Member
  • *****
  • Posts: 682
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #1 on: April 25, 2016, 04:06:18 am »
hello,
ϻαϻɾΣɀО  a dit :
Quote
What I'd completely removed the any version of both fpc and Lazarus!
Then reinstalled from Ubuntu repositories

have you deleted ~/.lazarus directory, the packages lazarus and fpc ? And see if in the /etc folder , if you have  a fpc.cfg, fppkg.cfg files and lazarus folder and delete them. Search on your whole disk if you have still some lazarus , fpc, fpcsrc folders (example  to search :  sudo find / -name lazarus ) and delete them.

Friendly, J.P
« Last Edit: April 25, 2016, 04:11:20 am by Jurassic Pork »

Chronos

  • Full Member
  • ***
  • Posts: 194
    • PascalClassLibrary
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #2 on: April 25, 2016, 03:41:23 pm »
Yesterday I upgraded one of my computer from Xubuntu 15.10 to 16.04 and fpc command was not working with some strange error message. I had previously installed fpc 3.0.0 and lazarus 1.6 from manually downloaded deb files and it was working ok. So to solve my issue I removed all previous packages starting with fpc- fcl- fp- lcl- lazarus using apt-get purge including some old config packages for older lazarus versions. Then I installed lazarus using apt-get install lazarus and it was working just fine.

So at least it is working ok for me on Xubuntu 16.04 amd64. But I can't say about clean lazarus installation on clean ubuntu installation.

ϻαϻɾΣɀО

  • New member
  • *
  • Posts: 26
  • error = (more code)² «» e=mc²
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #3 on: April 25, 2016, 07:35:06 pm »
hello,
ϻαϻɾΣɀО  a dit :
Quote
What I'd completely removed the any version of both fpc and Lazarus!
Then reinstalled from Ubuntu repositories

have you deleted ~/.lazarus directory, the packages lazarus and fpc ? And see if in the /etc folder , if you have  a fpc.cfg, fppkg.cfg files and lazarus folder and delete them. Search on your whole disk if you have still some lazarus , fpc, fpcsrc folders (example  to search :  sudo find / -name lazarus ) and delete them.

Friendly, J.P
Of course I did!
Lazarus starts successfully, And fpc compiles too but, But current situation is the removed/disappeared Packages that I said before.

I need at least AnchorDockingDsgn package  :(
error = (more code)² «» e=mc²

ϻαϻɾΣɀО

  • New member
  • *
  • Posts: 26
  • error = (more code)² «» e=mc²
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #4 on: April 25, 2016, 07:42:48 pm »
Yesterday I upgraded one of my computer from Xubuntu 15.10 to 16.04 and fpc command was not working with some strange error message. I had previously installed fpc 3.0.0 and lazarus 1.6 from manually downloaded deb files and it was working ok. So to solve my issue I removed all previous packages starting with fpc- fcl- fp- lcl- lazarus using apt-get purge including some old config packages for older lazarus versions. Then I installed lazarus using apt-get install lazarus and it was working just fine.

So at least it is working ok for me on Xubuntu 16.04 amd64. But I can't say about clean lazarus installation on clean ubuntu installation.

Huum
Your previously installation of the fpc and lazarus packages names are (fpc-src, fpc, fpc-3.0.0, lazarus) and the new packages provided by the Ubuntu repositories changed to (fp-..., lazarus1.6+dfsg-1) so after upgrade there is tow installation of fpc and lazarus too.
In this case calling fpc causes executing new installed fpc with wrong configuration that point to last installed fpc!

You are right, Clean installation of Ubuntu and ... works but missing packages provided with official Lazarus in this release make it difficult to daily work with Lazarus!
« Last Edit: April 25, 2016, 07:44:33 pm by ϻαϻɾΣɀО »
error = (more code)² «» e=mc²

vangli

  • New member
  • *
  • Posts: 8
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #5 on: April 25, 2016, 08:05:46 pm »
Yes, same happen to me when updating from Ubuntu 15.10 with Lazarus 1.6 installed from project debian packages. Had to deinstall all Lazarus/FPC packackes following Ubuntu 16.10, then reinstall from the projects debian packages. To hinder updating from the software manager, I also had to block those updates. The manager tried to update my manually installed packages.

I also tried to do it the other way around, using only the Ubuntu version. It didn't work. Maybe I could find a solution, but was getting rather irritable  >:D.

My solution was to stick to the published debian pacakages from Lazarus. They work  :D

Best regards

Bent, Oslo, Norway

Regards Bent

ϻαϻɾΣɀО

  • New member
  • *
  • Posts: 26
  • error = (more code)² «» e=mc²
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #6 on: April 25, 2016, 09:08:47 pm »
Hah
Everything ok! ;D
I just installed fpc from Ubuntu repository then get Lazarus from SVN abd compiled it!
Now Im running Lazarus 1.7 and everything is OK  ;)
« Last Edit: April 25, 2016, 09:12:23 pm by ϻαϻɾΣɀО »
error = (more code)² «» e=mc²

Chronos

  • Full Member
  • ***
  • Posts: 194
    • PascalClassLibrary
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #7 on: April 26, 2016, 06:32:28 pm »
I didn't mention that I also use trunk lazarus. I didn't tried to compile my projects in lazarus installed from ubuntu repo.

Now I updated also my second PC and got same error message as on first pc:
Error: ppcx64 can't be executed, error message: Failed to execute "ppcx64", error code: 127

In fact there shouldn't be just problem with renamed packages or even installed same packages with different name as such packages would have same files on filesystem and so they would fail during installation.

Chronos

  • Full Member
  • ***
  • Posts: 194
    • PascalClassLibrary
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #8 on: April 28, 2016, 08:45:44 pm »
Just the same problem on different computer also with Ubuntu 16.04 amd64. There are updated fpc packages available in repo with suffix dfsg-2 but still I got error during installation:
Quote
...
Unpacking fpc-source-3.0.0 (3.0.0+dfsg-2) …
dpkg: error processing package /var/cache/apt/archives/fpc-source-3.0.0_3.0.0+dfsg-2_all.deb (--unpack):
 trying to overwrite file „/usr/share/fpcsrc/3.0.0/rtl/android/jvm/java_sys_android.inc“ which is also in fpc-src 3.0.0
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously deselected package fp-utils-3.0.0.
...

Execution of aptitude remove fpc-src-3.0.0 fixed the problem.

Then as source files are not at same location with ubuntu packages in comparison to lazarus manual deb packages then /usr/share/lazarus-1.6 needed to be replaced by /usr/lib/lazarus-1.6.

Then another problem popped out: Warning: wrong version in ide/version.inc: 1.6+dfsg-1

Interesting is that fpc and lazarus split to bunch of packages is even not easy to remove as one need to go down to many various names of virtual and many other version specific packages:
sudo aptitude purge lazarus lazarus-ide lazarus-ide-1.6 lazarus-src-1.6 fpc fpc-source-3.0.0 lcl-utils-1.6 lcl-units-1.6 lcl-nogui-1.6 lcl-gtk2-1.6 lcl-1.6 fp-units-rtl-3.0.0 fp-units-gtk2-3.0.0 fp-units-fcl-3.0.0 fp-units-base-3.0.0 fp-compiler-3.0.0 fp-compiler

But even after manual removal of all these packages and clean install using aptitude install lazarus there is still same warning. Which can be ignored but still lazarus binary expect different version version then 1.6+dfsg-1? Don't know where is a problem...

TLabs-Peti

  • New member
  • *
  • Posts: 14
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #9 on: May 01, 2016, 05:53:51 pm »
Hi!

I had all the problems what u wrote above, but this helped:
http://installion.co.uk/ubuntu/xenial/universe/l/lazarus/install/index.html

Its really easy, and works simply.
At first it will offer you two directoryes for the IDE, but only one from the two options will work (its easy if you choose the wrong it will say missing LCL).

(I tried reinstall, from synaptic, tried the official install files from here, but this linked worked only)

jsuzineau

  • Newbie
  • Posts: 1
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #10 on: May 13, 2016, 01:59:24 pm »
Hi !
I have also experienced problems with ubuntu packages for lazarus and freepascal since Ubuntu 15.
I regurlarly try to use ubuntu packages (after cleaning every trace of freepascal and lazarus) but without success.

When I use the debian packages from http://www.lazarus-ide.org/, it works (I need to uninstall all the small ubuntu packages before).

Since I develop custom components, I need to recompile lazarus. Right after installation its fails because files under /usr/share/lazarus/ are installed with root permissions.
I've tried to execute lazarus-ide as root with something like :
sudo lazarus-ide &

But if I well remember, I ended up with config files with root permissions in my own account, and I could'nt run lazarus under my own account ( and you end up by making chmod 777 on everything ...)
Alternatively, I change owner and group on the whole lazarus directory:
  sudo chown -R jean /usr/share/lazarus/
  sudo chgrp -R jean /usr/share/lazarus/

and it works. May be it's not the best for security.

Sometimes Ubuntu confuses its own package fpc with the one from http://www.lazarus-ide.org/, then tries to update it, and I end up with broken packages and update manager not working.
This morning I had the idea to block updating for theses packages :
sudo apt-mark hold fpc
sudo apt-mark hold fpc-src
sudo apt-mark hold lazarus

I hope it will prevent ubuntu from trying to replace them with its own packages.

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3355
  • I like bugs.
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #11 on: May 13, 2016, 05:42:27 pm »
Since I develop custom components, I need to recompile lazarus. Right after installation its fails because files under /usr/share/lazarus/ are installed with root permissions.
I've tried to execute lazarus-ide as root with something like :
sudo lazarus-ide &


You should run "startlazarus" instead. It checks where the correct latest binary is and then runs it.

For the original author ϻαϻɾΣɀО: you certainly did not delete your ~/.lazarus folder.
Package EditorToolbar does not exist any more in 1.6 release. It must come from your old configuration.
« Last Edit: May 13, 2016, 05:48:07 pm by JuhaManninen »

ϻαϻɾΣɀО

  • New member
  • *
  • Posts: 26
  • error = (more code)² «» e=mc²
Re: Ubuntu 16.04 And Lazarus 1.6+dfsg-1 :-O
« Reply #12 on: May 16, 2016, 08:50:49 pm »
Since I develop custom components, I need to recompile lazarus. Right after installation its fails because files under /usr/share/lazarus/ are installed with root permissions.
I've tried to execute lazarus-ide as root with something like :
sudo lazarus-ide &


You should run "startlazarus" instead. It checks where the correct latest binary is and then runs it.

For the original author ϻαϻɾΣɀО: you certainly did not delete your ~/.lazarus folder.
Package EditorToolbar does not exist any more in 1.6 release. It must come from your old configuration.

As I said before I'd deleted everything even ~/.lazarus
Bu I need packages I mentioned above,
For this problem install fpc from repo and compile Lazarus from trunk if you need native Lazarus packages.
Also 
Package EditorToolbar does not exist any more in 1.6 release. It must come from your old configuration.
Yes as mentioned here http://wiki.freepascal.org/Lazarus_1.6.0_release_notes#IDE_Changes EditorToolbar which was moved to IDE's codebase!
But the "anchordockingdsgn" package disappeared, Which I need, so if anyone need this package he must compile it from trunck source!
error = (more code)² «» e=mc²

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus