* * *

Author Topic: Cannot compile InternetTools  (Read 1535 times)

JD

  • Hero Member
  • *****
  • Posts: 1573
Cannot compile InternetTools
« on: April 02, 2016, 11:43:22 pm »
Hi there everyone,

I downloaded InternetTools from http://www.benibela.de/sources_en.html#internettools.

I tried to compile internettools.lpk & I got the following error

Code: Pascal  [Select]
  1. xquery__regex.pas(45,23) Fatal: Cannot find FLRE used by xquery__regex of package internettools.

In addition, the other package internettools_utf8.lpk depend on utf8tools (see screenshot) & I can't seem to find it.

Can anyone help me out?

JD

Windows (10, 7) - Lazarus 1.6.4/FPC 3.0.2 (also Delphi occasionally)
Linux Mint Cinnamon  - Lazarus 1.4/FPC 2.6.4
Indy 10.6 series; Zeos 7.2.1; SQLite, Firebird, PostgreSQL & MariaDB

Jurassic Pork

  • Hero Member
  • *****
  • Posts: 620
Re: Cannot compile InternetTools
« Reply #1 on: April 02, 2016, 11:57:59 pm »
hello JD,

add 
Code: Pascal  [Select]
  1.  {$DEFINE USE_SOROKINS_REGEX}
( which enables the unit regexpr coming with fpc. )
at the beginning of the file because maybe you have'nt the sources of FLRE regexpr.
You need the sources of the other regexp units to enable them. (dregexpr.pas is in the folder of internetTools import\regexpr\source).

Friendly, J.P


aradeonas

  • Hero Member
  • *****
  • Posts: 824
Re: Cannot compile InternetTools
« Reply #2 on: April 03, 2016, 10:22:29 am »

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus