* * *

Author Topic: Mac OS 10.8.5, Xcode 5, fpc 2.6.2, ...  (Read 1783 times)

WalterK

  • New member
  • *
  • Posts: 48
Mac OS 10.8.5, Xcode 5, fpc 2.6.2, ...
« on: October 14, 2013, 10:51:31 pm »
I have a new Intel iMac on which I want to load fpc/lazarus.

I've installed Xcode 5.  Attempting to install fpc-xcode-2.4.0 tells me I have to add Unix support.  Following the wiki entry here:
http://wiki.freepascal.org/Installing_Lazarus_on_MacOS_X
I open a terminal window and enter "xcode-select --install" which gives me the error message:

-----
xcode-select: Error: unknown command option '--install'.

xcode-select: Report or change the path to the active
              Xcode installation for this machine.

Usage: xcode-select --print-path
           Prints the path of the active Xcode folder
   or: xcode-select --switch <xcode_path>
           Sets the path for the active Xcode folder
   or: xcode-select --version
           Prints the version of xcode-select
-----

with no dialog box asking to install command line tools.

It looks like they're already installed, but I still got the install block from fpc-xcode.

What to do?

Jonas Maebe

  • Sr. Member
  • ****
  • Posts: 307
Re: Mac OS 10.8.5, Xcode 5, fpc 2.6.2, ...
« Reply #1 on: October 14, 2013, 10:59:42 pm »
You don't need the fpc-xcode-2.4.0 package: it only installs Xcode templates for Xcode 3.x, as its readme specifies. It indeed checks for a file that is only installed by older Xcode versions.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 3036
    • wiki
Re: Mac OS 10.8.5, Xcode 5, fpc 2.6.2, ...
« Reply #2 on: October 14, 2013, 11:04:27 pm »
Once you got Lazarus installed, please read http://forum.lazarus.freepascal.org/index.php/topic,22328.0.html

This is about building, GDB, and configuring Lazarus to use it.

WalterK

  • New member
  • *
  • Posts: 48
Re: Mac OS 10.8.5, Xcode 5, fpc 2.6.2, ...
« Reply #3 on: October 14, 2013, 11:22:48 pm »
Thanks.  I've progressed to the "Can not find Interfaces" error, which I'm sure is addressed in the forums.  So, I'll check back when I get passed that.

WalterK

  • New member
  • *
  • Posts: 48
Re: Mac OS 10.8.5, Xcode 5, fpc 2.6.2, ...
« Reply #4 on: October 14, 2013, 11:50:09 pm »
I had old PowerPC files/directories moved over from the old Mac - I deleted many/most of these and finally got an empty project to compile and run.  So for now I think I'm good.

Thanks.

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus