* * *

Recent Posts

Pages: [1] 2 3 ... 10
Android / Re: LazToApk 0.9.38 is available now.
« Last post by DelphiFreak on Today at 12:57:11 pm »

nothing has changed in CustomDrawn components. It looks like the development of this has "stalled".
Therefore I would like to move to LAMW. That's why I updated the installation PDF.
It describes how to install LAMW.
I also added the automatic download of ANT to laztoapk because LAMW needs that stuff somehow.

I played around a little with LAMW, but had also the expirence that some demo apps worked and some crashed.
Sorry I have no time/interest to dive deeper into this android stuff.

Next step would be to change laztoapk-GUI to compile LAMW projects.

Have fun.

General / Re: Recompile the RTL to debug
« Last post by molly on Today at 12:54:34 pm »
If you specifically use the 3.0.4 bootstrap compiler (ppc386.exe for windows 32-bit) running in it's own location then you should be good to go.

Meaning, that in case you receive such messages about using -Xs that there is probably something else bugging you. You should _not_ modify the makefiles. They should be good to go, as they are clean. With every (failed) make attempt, you should run "make clean" twice (or better yet in order to make sure, delete the lot and extract again).

For every other error(s) that might pop-up: there is a log-file so use it wisely :). Additional (verbose) options are allowed to produce even more extensive information.

Do note however, that i have no experience running the same script on a mac. Your mileage may vary... but in case of errors, they should be clear reported errors.

In case the same error is also happening for you when you use the 3.0.2 compiler in order to create a complete 3.0.4 compiler with debug/linenumbers added to the build files then that would be a clear indication something is crossing your setup. If not, then there is something seriously wrong with mac version: the 3.0.2 compiler _must_ be able to compile the 3.0.4 compiler, no matter what (exotic host/targets perhaps excluded). If not, then that is to be considered a bug.

A good nights rest, sometimes does wonders though  :D

PS: I just had a thought. Are you perhaps able to post a dump of your shell environment variables ? There are a few that overrule/add to your compiler settings. Those should be cleared. For me personally i once had (if i remember correctly) env compiler_options set, which wasted quite an extensive amount time. No option added and still those options where used for compilation. A bit like a fata-morgana in a cardboard box :)
Android / Re: LazToApk 0.9.38 is available now.
« Last post by kupferstecher on Today at 12:47:50 pm »
I learned from Handoko that in the last versions of LazToApk with CustomDrawn the android versions 5 and higher are not support (app crashes). At least a test with a app compiled with LazToApk failed on android 5.

Perhaps it's (still) the same thing?
General / Re: Recompile the RTL to debug
« Last post by dbannon on Today at 12:33:59 pm »
Nope !  Removed the -Xs from two places in Makefile but build still includes the infamous -Xs

I note -dRELEASE too, got to be related.


Too late, going to bed.


Lazarus Extra Components / Cant find DomExt
« Last post by ednaldomoreira on Today at 12:27:33 pm »
Hi guys,

I can't find the DomExt describe in this link


Where is this unit ?
Spanish / Re: Compilacion Cruzada a RaspBerry Pi
« Last post by Thaddy on Today at 12:24:58 pm »
It is not that easy. NewPascal is not supported on THIS forum. Although the core team reads this forum.

But the solution is easy: install the official release on your raspberry pi and compile natively. The Raspberry Pi is perfectly capable as a native platform.
See: https://www.freepascal.org/down/arm/linux-netherlands.var

Note there are two different files. If you have a RPi3 or second generation RPi2, choose the first one. (armv7a eabihf)
If you have a Raspberry Pi zero, a Raspberry Pi 1 or a first generation RP1 2 choose the second one.(armv6 eabihf)

BTW: The second one works on all Raspberry pies.
You can program the backend, database model and web server using Object Pascal quickly at very efficient manner (Using mORMot for example). GUI is another history...

The above quote is the way my database progs are written.
First, a server is made. With an embedded sqlite3 engine. Testing: Windows; running: Linux.
Followed by a windows/linux client app. With local and remote (the server) database (single change: 2 lines of code).
The above allows for very easy testing and GUI.
Followed by an Android app with LAMW with local database for easy testing. Followed by the remote database connection.
Database logic is shared between all clients and the server(s).
As an extra, Javascript clients (JSON, remote server) allow for many more clients.

Honest sidenote: (only) after a (steep) learning curve, the productivity will become very high.
General / Re: Recompile the RTL to debug
« Last post by dbannon on Today at 12:20:41 pm »
Wow Molly, thats just about a publication ! I am seriously grateful !

However, I'm being hard to get along with ! 

Firstly, I'm on a Mac now, thats where the problem exists, I was using Linux while feeling my way around but have to make it work on the Mac. Your ftp site does mention freeBSD bootstrap compilers, honestly, I know so little about Mac that I don't know....

Secondly, I now have both the 3.0.4 and the 3.0.2 compilers running on my Mac. So, much of its done. I have them tucked out of the way so I can reconfigure or butcher without causing any real problems. I hope :-)

The 32/64 bit issue is all about a stupid typo in my scripts, compile is running now, as we speak. But I'm still getting a -Xs after I commented out both -Xs in the 'in use' fpc.cfg.  Looks like its coming in from the Makefile, going to have a read.....
General / Re: lazarus beginer quetions
« Last post by Thaddy on Today at 12:09:51 pm »
There are many things wrong with your code, but try this:
Code: Pascal  [Select]
  1. program untitled;
  2. {$ifdef fpc}{$mode objfpc}{$modeswitch advancedrecords}{$H+}{$endif}
  3. type
  4.   TReal3d = record
  5.     x , y , z : Double;
  6.     procedure Initialize( const a , b , c : double );
  7.   end;
  9. procedure TReal3d.Initialize(const a,b,c :double);
  10. begin
  11.    x:=a;
  12.    y:=b;
  13.    z:=c;
  14. end;
  16. operator + (const  a , b : TReal3d ): TReal3d;
  17. begin
  18.   Result.x := a.x+b.x;
  19.   Result.y := a.y+b.y;
  20.   Result.z := a.z + b.z;
  21. end ;
  23. function cross(const a ,b :TReal3d):TReal3d;
  24. begin
  25.   Result.x := a.y * b.z - a.z * b.y;
  26.   Result.y := a.z * b.x - a.x * b.z;
  27.   Result.z := a.x * b.y - a.y * b.x;
  28. end;
  30. var aa,bb,cc,crossme:TReal3d;
  31. begin
  32.   aa.initialize(1.0,2.0,3.0);
  33.   bb.initialize(3.0,2.0,1.0);
  34.   cc := aa + bb;
  35.   writeln(cc.x);
  36.   crossme := cross(aa,bb);
  37.   writeln(crossme.x);
  38. end.

Note object is deprecated, you should use records or classes, not object
Note real is deprecated, it is now an alias for double. (although there is a unit that supports old school real, as in real48)
Note that your type of code, with all the errors corrected, is allowed and will still work. But you should learn from a more modern source, at least beyond 1995.
Spanish / Re: Compilacion Cruzada a RaspBerry Pi
« Last post by turrican on Today at 12:06:33 pm »
Es muuuy senzillo.

Yo lo que haría para facilitarte la vida es descargar lo siguiente :


Este gestor de plataformas FPC + Lazarus te instalará todo lo necesario para compilar para el objetivo ARM + Linux.

Y sin ningún dolor de cabeza.
Pages: [1] 2 3 ... 10


Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus