* * *

Author Topic: How to config lazarus for arm processors(Neofreerunner- openmoko)?  (Read 4093 times)

Amir61

  • New member
  • *
  • Posts: 11
    • http://Amir.Aavani.net
Hi,

I have a newfreerunner smartphone and I want to try to develop some application for it. I have searched throught fpc-pascal mailing list and this forum but still I can't figure out how to make it work. I am using lazarus under Linux.

In fact, I couldn't find any rpm for the arm cross compiler. Although, I tried to install fpc-2.2.2.arm-linux.tar based on http://wiki.lazarus.freepascal.org/Setup_Cross_Compile_For_ARM (which is out of date-- the links in that page do not work anymore). I created an empty project and set the compiler options/code/Target Platform appropriately. When I tried to compile the project, Lazarus tries to run the following command:
[TCompiler.Compile] CmdLine="/usr/bin/fpc  -MObjFPC -Sgi -O1 -Parm -gl -WG -vewnhi -l -Fi/ -Fu/usr/lib/lazarus/lcl/units/arm-linux/ -Fu/usr/lib/lazarus/lcl/units/arm-linux/gtk/ -Fu/usr/lib/lazarus/packager/units/arm-linux/ -Fu. -dLCL -dLCLgtk /tmp/project1.lpr"

and I get the following error:
Error: ppcarm can't be executed, error message: Failed to execute "ppcarm", error code: 127

When I try to run the ppcarm directly from terminal, I get "bash: /usr/bin/ppcarm: cannot execute binary file" error.



« Last Edit: August 21, 2009, 08:05:49 pm by Amir61 »

BlueIcaro

  • Sr. Member
  • ****
  • Posts: 487
Re: How to config lazarus for Neofreerunner (openmoko)?
« Reply #1 on: August 21, 2009, 09:37:22 am »
Did you installed before a copy of lazarus?. You must install lazarus first, the version that fits for your system (linux, windows, macos), and then install cross-compiler package.

/BlueIcaro
Remenber, the lazarus wiki is your friend: http://wiki.lazarus.freepascal.org/Main_Page
General questions (several lenguages) http://wiki.lazarus.freepascal.org/

Amir61

  • New member
  • *
  • Posts: 11
    • http://Amir.Aavani.net
Re: How to config lazarus for Neofreerunner (openmoko)?
« Reply #2 on: August 21, 2009, 08:05:13 pm »
In the first step, I installed the cross compiler fpc-2.2.2.arm-linux.tar.
Then, when I tried to run fpc I got an error like following:
bash: /usr/bin/fpc: cannot execute binary file

So, I tried to reinstall the fpc and fpc-src and lazarus using yum.


 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads