Using the Lazarus IDE > Debugger

Lazarus cant run with comodo firewall

(1/2) > >>

didi:
Hi I am a user of Comodo firewall, and I am very funned of it.
I have recently installed Lazarus, wich cannot run the debugger, if comodo is installed

This was covered in the thread http://www.lazarus.freepascal.org/index.php?topic=6225.0

But is there no way arround this, other than uninstalling Comodo ? I have tried to play with comodo settings, but cant make it work. And I am vary noop in Lazerus. I would like to use the debugger, so I dont want to turn this one off.

Any suggestions are appreciated

Kond Regards

Paul Ishenin:
The issue you have relates to gdb only and very indirectly to lazarus project. Therefore better to ask for help either Comodo or gdb support teams.

LuizAmérico:

--- Quote ---But is there no way arround this, other than uninstalling Comodo ?
--- End quote ---

Yes. Disable Defense +

mjen:

--- Quote from: didi on July 17, 2009, 10:03:54 am ---Hi I am a user of Comodo firewall, and I am very funned of it.
I have recently installed Lazarus, wich cannot run the debugger, if comodo is installed

This was covered in the thread http://www.lazarus.freepascal.org/index.php?topic=6225.0

But is there no way arround this, other than uninstalling Comodo ? I have tried to play with comodo settings, but cant make it work. And I am vary noop in Lazerus. I would like to use the debugger, so I dont want to turn this one off.

Any suggestions are appreciated

Kond Regards

--- End quote ---


Hello everyone!
Here is the solution to the above problem!  :D
The Comodo forum I found this link: http://forums.comodo.com/defense-sandbox-help-cis/gdb-problem-solved-t47299.15.html


I also have problem with SIGSEGV message when running a new program with gdb.exe under lazarus.
I then ran gdb.exe through windows cmd.exe, and found out the dgb.exe detected problem with guard32.dll. (Running dgb.exe under lazarus does not show this level of detail).

I tried all of your suggestions, and I have come up with the following steps that works for me.
I am using Comodo version 5.3.

Step 1. (Make a group of folder that contains the gdb's working directory, and your program's directory). This is the most elaborate part).

CIS --> Defense+ --> Computer Security Policy --> Protected Files and Folders --> Groups.

You are now in File Groups. Click Add --> A New Group.

Give the new group a name (I used "lazarus GDB" but you can name it anything you want). Click Apply.

You are back in File Groups. Find the new group in the list and select "add files here" underneath. Then Click Add --> Browse.

Find the gdb.exe directory in the treeview presented and select it. (In my case, I selected "c:\lazarus\mingw\bin*"). Do not select gdb.exe itself.

Find the directory of your program that dgb.exe debugs and select it. Do not select the program itself. For example, I have "c:\lazarus-projects*", I did not select "c:\larazus-projects\project1.exe".

Click Apply. Now you have a group of folders (not group of files).

Step 2. Add the group you have created to "Protected Files and Folders".

CIS --> Defense+ --> Computer Security Policy --> Protected Files and Folders --> Add --> File Groups.

You should be able to find the Group of Folders that you just created (In my case, "Lazarus GDB").

Select it, so that you can go to Step 3.

Step 3. (Add to the Exclusion List). The Image Execution Control Settings have been relocated and renamed. In my version of Comodo, it is under...

CIS --> Defense+ --> Defense+ Settings --> Execution Control Settings.

There is a button "Exclusions" next to "Detect Shellcode Injections (i.e. Buffer Overflow Protection)". Click it.

The Exclusion list comes up. Click Add --> File Groups. Pick the Group of Folders you created. Click Apply.

Back in Defense+ Settings. Click OK.

All done.

With this I have no problem with SIGSEGV ... so far. Hope it helps.

If it works, credit goes to all of you who have all supplied the bits of information that led to this.
I have attached a pdf of the forum for you to see my comments. No disrepect intended, and I appreciate your comments / feedbacks.


bobihot:
Comodo give me, that in gdb file of compiled project have a trpyan:

Date    Location    Malware Name    Action    Status
2013-06-24 Suspi1.dbg     TrojWare.Win32.FraudPack.P@179389676     Detect     Success
2013-06-24 15:33:39     G:\WORK\Suspi\Suspi1.dbg     TrojWare.Win32.FraudPack.P@179389676     Quarantine     Success 

Are they a virus, or false detection from Comodo?
I resolved when change linker settings for dbg.

Navigation

[0] Message Index

[#] Next page

Go to full version