* * *

Author Topic: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)  (Read 21870 times)

Kunstbanause

  • New member
  • *
  • Posts: 47
One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« on: January 29, 2009, 11:22:18 pm »
I changed my harddisk on my notebook. After I reinstalled Ubuntu 8.10 x86_64 I now have this weird problem.
When I try to enter text anywhere within the IDE (ObjectInspector, Options, ...) or within a compiled application the pressed key is displayed twice.

For example:
When I try to to enter "FreePascal" it ends up with "FFrreeeePPaassccaall".

Maybe I forgot to install a needed package or it's just any setting of Ubuntu itself, but I do not have any clue where to start to solve the problem and this problem only occurs within Lazarus and any application I compiled.

Greetings,
Marc

Bart

  • Hero Member
  • *****
  • Posts: 2719
    • Bart en Mariska's Webstek
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #1 on: January 30, 2009, 02:42:50 pm »
This is not a bug, it is new Lazarus feature  >:D

Kunstbanause

  • New member
  • *
  • Posts: 47
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #2 on: February 03, 2009, 08:34:33 pm »
I just found a bug report for that:

http://bugs.freepascal.org/view.php?id=12600

dstasinski

  • Newbie
  • Posts: 4
Re: One keypress, two characters (GTK2 on Fedora 10)
« Reply #3 on: February 22, 2009, 11:13:16 pm »
This same problem started for me as of yesterday.   Any fix available?

Daniel

dstasinski

  • Newbie
  • Posts: 4
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #4 on: February 23, 2009, 10:51:07 pm »
I tracked down the cause of this, SCIM (The Smart Common Input Method platform).  Once disabled, no more double-characters.

Daniel

frank_t

  • Newbie
  • Posts: 3
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #5 on: March 09, 2009, 03:56:46 am »
I tracked down the cause of this, SCIM (The Smart Common Input Method platform).  Once disabled, no more double-characters.

Daniel

I met across this problem, too.
I do enabled scim.
Since you find what's wrong, can you fix this, please?
 :D

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2660
    • My Lazarus wiki user page
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #6 on: March 10, 2009, 06:51:38 pm »
You don't know how to disable the SCIM?

mutex

  • Newbie
  • Posts: 2
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #7 on: April 08, 2009, 03:29:24 am »
i got the same problem base on fedora10. some one could tell me how to fix it?

lonelycorn

  • Newbie
  • Posts: 1
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #8 on: April 12, 2009, 06:15:54 pm »
i've tried and found that the GTK2 programs lazarus compiled conflict with scim-bridge,a scim binding.GTK1 is ok,and GTK2 programs compiled with other compilers are ok too.

mutex

  • Newbie
  • Posts: 2
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #9 on: April 22, 2009, 04:45:26 am »
i've tried and found that the GTK2 programs lazarus compiled conflict with scim-bridge,a scim binding.GTK1 is ok,and GTK2 programs compiled with other compilers are ok too.

hello
could you inform me how to handle in detail?  and compiled with which compilers?
« Last Edit: April 22, 2009, 05:21:39 am by mutex »

wbeppler

  • New member
  • *
  • Posts: 7
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #10 on: October 24, 2014, 06:25:41 pm »
do following:

QT_IM_MODULE=xim <name of program with problem> #  KDE/QT-Anwendungen

or do this: (it worked by my computer)
GTK_IM_MODULE=gtk-im-context-xim <name of program with problem> #  Gnome/GTK-Anwendungen

in detail:
GTK_IM_MODULE=gtk-im-context-xim startlazarus

bozcan

  • New member
  • *
  • Posts: 5
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #11 on: January 30, 2015, 11:19:21 am »
ALSO I didn't make it, I try everything but it agains types 2 characters when I pressed 1.

terry6

  • New member
  • *
  • Posts: 6
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #12 on: February 01, 2015, 05:32:58 am »
lubuntu 14.10
lazarus 1.2.4+dfsg-1
fpc 2.6.4
x86_64-linux-gtk 2

New install. Copied project files from Windows where I have a working exe file. Compiled after removing windows specific files. Everything worked. Ran the compiled file and entering data into an edit field got 2 characters for every one I entered.
Tried editing code and got double characters whenever I typed.
Compiled a test project with just a memo field and when I typed it doubled each letter.
Also ran a compiled file as an executable outside Lazarus and got the same result.
Considering the amount of time this bug has been around I would think there is someone who has a clear solution. Everything works beautifully but I can not type any code or enter data. >:D

bozcan

  • New member
  • *
  • Posts: 5
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #13 on: February 02, 2015, 03:20:45 pm »
is there any replies to solve this problem _? it's urgent

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 4350
    • wiki
Re: One keypress, two characters (GTK2, Ubuntu 8.10 x86_64)
« Reply #14 on: February 02, 2015, 04:54:04 pm »
Probably best to report it as a bug, which as much details (os, gtk version, windownamanger, ...) as possible.

Also best to indicate, if the issue only happens with IM or with/without. (and which keyboard layout is used, does an english layout fix it?)


IIRC some previous issues with key-presses existed only, when the installation was in a virtual machine, or some sort of remote access was used (VNC).

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus